5

I use iCal's month view, so when creating an event I put it as all-day and put the event time in the title, like so: "3:30 meeting with Steve", "9am-10am TYO-NYC flight" (if you find it unusual, I'm not the only one doing this, and this style has benefits such as when dealing with time zones). iCal promptly removes the time from the title and changes the event from all-day to the new time, so I have to edit it again.

Same thing with Reminders application. Even more annoyingly, if you put a link containing a date (eg. http://www.tofugu.com/2013/06/04/how-to-write-letters-in-japanese-an-introduction/), it will convert this to a "remind me on this day" date as well.

It looks like it cannot be turned off anywhere in Preferences, but maybe there is a setting accessible from the command line?

(So far I found only one suggestion online, and it was to type the date twice - iCal will remove one date, but keep the other. While this works, it's annoying and you still need to change the even back to "all-day" and I hope there's a better way.)

I'm running Maverick with all the latest updates.

1

iCal is to clever for its own good, it automatically assume you want to have a event at 3:30.

I use the same system as you with worldwide travel and timezones.

I use a trick to fool the iCal.

Just do not use the correct time format so iCal wont know it is time but you will :)

not 3:30

use 3,30

now it thinks it is text not time.


To your second question. about Reminders, I pasted that link as reminder tittle and it stay put to the date I want, so maybe you need to explain that problem.

  • 1
    This works but I hate Apple for this. Sometimes I forget to enter a time and because of this "Feature", I have no way of knowing if the time is set because I typed it in and then iCal removed it, or because it just defaulted to whatever when I created the event... – billynoah Apr 20 '15 at 22:36
  • 1
    @billynoah sorry for that, Apple was just trying to think for you, something they should not be doing. – Ruskes Apr 20 '15 at 23:36
  • it appears they finally removed this automatic behaviour in a recent iCal version! – margold Jul 7 '15 at 12:41
1

Since data detectors are handled by Mail & not iCal itself you may turn this feature of with the following command entered in Terminal:

defaults write com.apple.mail DisableDataDetectors YES

To revert this behaviour:

defaults write com.apple.mail DisableDataDetectors NO

Please note that any time detection features of Mail are turned of as well.

0

I just recently updated from Mountain Lion to El Capitan and discovered that the iCal option to not show event time in month view was no longer available. I found a work around by checking "all day" and putting the time either in the location or notes area. Now the event time does not take up space in the event title line. I double click on the event line to see the time if I have to. Good for me for now until Apple fixes this. Of course this means the time does not show up in any other view as well, so it's only a temporary fix. I did post feedback to Apple about this iCal oversight using the link provided on this page.

  • Probably obvious, but this does not affect data detection in the Reminders app. – Andrew Swift Jan 31 '18 at 14:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .