It used to work fine. There is no physical damage to the MacBook and the WiFi network I'd like to connect is is perfectly functional.

It will not connect to any WiFi network or ethernet-based networks.

How can I fix this?

Sometimes, the wifi status is in the top bar, but when I click on it, it says "No Wi-fi Hardware Installed".

  • What's the model and year of the MacBook? Commented Oct 18, 2014 at 3:46
  • any solution to this???
    – Sunil Lama
    Commented May 21, 2017 at 14:27

3 Answers 3


Is it possible you inadvertently disabled wi-fi and ethernet in system preferences > network? If they are not listed in the left hand column of that window you can add them back by clicking the plus sign to 'create a new service' and then setup wi-fi and ethernet. It's nothing more than picking them from the list of services and then clicking 'Apply'

  • I just tried to click on the plus sign, but there was no wifi option. There was only Ethernet, Firewire, PPPoE, 4 to 6, and Bluetooth PAN options.
    – user81470
    Commented Jun 11, 2014 at 23:31
  • There is also a checkbox called "Show Wi-Fi status in menu bar" that you may need to check.
    – aharris88
    Commented Aug 15, 2016 at 15:24

Try to manually connect to WiFi using your Terminal (copy-paste following):

  • Turn On Wi-Fi

    networksetup -setairportpower en0 on
  • Find a network (you can skip this if you know the info already).

    /System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan
  • Connect to the network

    networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

You can try this to turn it on with sudo ifconfig en0 up

If none of this worked:

Check under About this Mac for WiFi showing something like this:


  • It says that "You cannot set Wi-fi power because all AirPort network services are disabled."
    – user81470
    Commented Jun 11, 2014 at 21:44
  • ok, lets turn it on with sudo ifconfig en1 up
    – Ruskes
    Commented Jun 11, 2014 at 23:44
  • heres the response: "ifconfig :interface en1 does not exist"
    – user81470
    Commented Jun 11, 2014 at 23:47
  • @Buscar웃 sudo ifconfig en1 up should be en0, no ? Commented Jun 12, 2014 at 7:31
  • sorry, you are right - en0 as zero
    – Ruskes
    Commented Jun 12, 2014 at 10:06

Make sure the system isn't running in Safe Mode (-x arg in nvram -p).

If not, in Terminal or in single-mode run:

sudo networksetup -listallnetworkservices

If you see an asterisk (*) next to your WiFi, it means the service is disabled. Enable it by:

networksetup -setnetworkserviceenabled WiFi on
networksetup -setairportpower en0 on

Same for any other network services which are disabled. See also this post.

Then restart your system to enable these services at startup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .