4

Today, out of no-where Chrome just started showing invalid SSL certificate errors for popular sites like Github, Stripe, etc.

The site's security certificate is not trusted!

I know the SSL certificates are valid, because my iMac on the same network works just fine.

I've cleared all cached and settings. Reinstalled chrome to the latest version. Checked that date/time set to automatically update in OSX.

Honestly, not sure what is going on.

4 Answers 4

4

I had this same problem. Open Keychain Access in Applications>Utilities. Make sure the selected keychain (top left) is login and the category (middle to bottom left) is certificates. Right click on any certificates labeled DigiCert and delete them. That should fix the problem.

1
  • 1
    Thanks so much that worked. Not sure what happened but...
    – Justin
    Jun 10, 2014 at 22:45
8

An old certificate expired on July 26h, 2014. Many users had it stored in their keychains, causing the errors you saw. Here is a detailed solution:

Based on https://www.yesthatallen.com/fixing-an-old-digicert-issue/

Instructions for clearing expired DigiCert SSL certificate on OSX

  • Launch Keychain Access via Spotlight
    • ⌘-Space
    • Type "Keychain Access"
    • Hit return
  • Ensure expired certificates are shown; enable "Show Expired Certificates" in the "View" menu.
  • Search for "Digicert".
  • Right-click the certificate with a red X and select "Delete DigiCert High Assurance EV Root CA"
  • The certificate may not look removed until Keychain Access is restarted
  • Restart your browsers
  • You should once again be able to access the affected sites.
  • Run Software update if problems persist, to make sure the latest root certificates from Apple are in place.
2
  • Any way to ensure the same problem doesn't happen again?
    – Justin
    Jul 30, 2014 at 17:53
  • Thanks all for your insight. I had to also delete some VeriSign certs that were “from an unknown authority”. In case anyone else lands here. Oct 6, 2015 at 14:04
0

This helped me:

(chrome, OsX)

  1. Open Keychain.app
  2. Search "digicert" in the top-right corner of Keychain.app
  3. Select all digicert certificates and remove them with right click and context menu (http://screencast.com/t/2T4f1XQa0Xu)
  4. Go here http://digicert.com/digicert-root-certificates.htm
  5. Find on page and Download DigiCert High Assurance EV Root CA certificate
  6. When downloaded - click on it and install it into your keychain
  7. Restart your chrome
0

I know this question is quite old, but I just had the same error message using my Chrome browser (Today is 18 Feb 2021) and I did all of the above but that didn't resolve it. Instead I discovered my Chrome Browser had an update pending and by completing the update and restarting my browser everything worked again. (new chrome Version 88.0.4324.182 (Official Build) (x86_64)). I rarely restart my Mac unless there's an update and so my apps can be running for some time before these updates would get applied. Maybe this will help someone else!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .