I have recently created a partition on my macbook air running OS X 10.9, and this was to run install another OS instance (Yes, OS X 10.10 Yosemite, but that is an aside to the query I have) on it.

I got the partition running fine, with the OS working fine as well, but now when I go back into Disk Utility, I noticed two things that are wrong:

  • Firstly, the disk that houses the two partitions has taken the name that I had thought I had given the new partition ("Yosemite"), instead of what it originally said, somewhere along the lines of "125GB Hard Drive" or similar.

  • Perhaps due to this, I believe, the tabs have changed when I select this disk, and I can no longer resize the partitions. The options are greyed out, and I cannot drag to resize either.

The Disk Utility looks similar to that seen in this question: Unable to adjust partition of USB drive with Mountain Lion Disk Utility though my computer is not encrypted, and it is the computer, not the USB I am having trouble with.

I tried entering Disk Utility from the Recovery Mode (by holding down option at start up), but the problem still persists. I have tried changing the start up discs between the two, but still nothing changed in the menu.

I believe that a reason for this problem is that somehow the drive is now a logical volume group. I don't really understand what this is, and how to fix it.

Note, this question is purely about partitioning, I do intend to use Yosemite on the partition when it is working, but at present it's a plain Mavericks system with a partitioning problem.

Here is an image of my Disk Utility: Screenshot of Disk Utility

  • please check my edits, I am not sure if you have actually installed Yosemite on the 2nd partition yet or not. At first I thought not, now I think you have. Just trying to word it to prevent Yosemite off topic flags, as I believe the issue is valid and not related to the pre-release software.
    – stuffe
    Commented Jun 10, 2014 at 10:00
  • Please reproduce this under 10.9 - your screen shot shows 10.10 disk utility which is hard to know if it's the problem without reproducing things on a shipping OS.
    – bmike
    Commented Jul 30, 2014 at 16:54
  • Worth noting, if a user intends to shrink an LV then add an LV: apple.stackexchange.com/a/146296/8546 shows OS X 10.9.5 apparently failing to add an LV to an LVF. That type of addition was reportedly possible in February 2013 (before Mavericks) so there may be a regression. Commented Sep 24, 2014 at 19:05
  • I started writing a long-winded comment but submitted an answer instead. The problem for me was that Disk Utility couldn't resize the primary partition while the partition was mounted as the filesystem root. See answer below.
    – AL the X
    Commented May 4, 2016 at 15:46

11 Answers 11


If I understand your question correctly you are trying to resize the volume group or actually one of the volumes within a group. From what I could gather your disk was converted to a CoreStorage Volume. Could you please verify that by issuing the following command in a terminal and check if you get a similar output to the one in the picture:

diskutil corestorage list

Output from diskutil

The currently available Disk Utility doesn't support resizing of logical Volumes. However using the command line, there is a undocumented function that allows you to resize Volumes.

If you consult the help command of diskutil you will receive the following output:

chris$ diskutil corestorage

Usage:  diskutil [quiet] coreStorage|CS <verb> <options>,
    where <verb> is as follows:

 list                     (Show status of CoreStorage volumes)
 info[rmation]            (Get CoreStorage information by UUID or disk)
 convert                  (Convert a volume into a CoreStorage volume)
 revert                   (Revert a CoreStorage volume to its native type)
 create                   (Create a new CoreStorage logical volume group)
 delete                   (Delete a CoreStorage logical volume group)
 createVolume             (Create a new CoreStorage logical volume)
 deleteVolume             (Delete a volume from a logical volume group)
 encryptVolume            (Encrypt a CoreStorage logical volume)
 decryptVolume            (Decrypt a CoreStorage logical volume)
 unlockVolume             (Attach/mount a locked CoreStorage logical volume)
 changeVolumePassphrase   (Change a CoreStorage logical volume's passphrase)

As you can see, it doesn't offer any option of resizing a Volume, hence my guess why Disk Utility doesn't allow you to resize.

However the following undocumented functions exists:

    chris$ diskutil corestorage resizeVolume

Usage:  diskutil coreStorage resizeVolume
        lvUUID|MountPoint|DiskIdentifier|DeviceNode size
Resize a logical volume, which is one of one or more disks that consume storage
out of a logical volume group. The logical volume group will have more or less
available space after this operation, if it was a shrink or grow, respectively.

Example: diskutil coreStorage resizeVolume
         11111111-2222-3333-4444-555555555555 10g

The resizeVolume function isn't listed in the first listing of available commands above but it still exists and it even provides you with an example on how to use it.

With this command and the correct UUID of the Volume it should be possible to resize one of the Volumes within your logical group.

I did some more digging around the command line and came across the following commands:

Physical Volume (Disk) Commands

  • resizeDisk (undocumented) – Resize a physical volume
  • removeDisk (undocumented) – Remove a physical volume from a logical volume group
  • addDisk (undocumented) - Add a new physical volume to a logical volume group

Logical Volume Commands

  • deleteVolume (undocumented) – Delete a logical volume and all of its contents
  • resizeVolume (undocumented) – Grow or shrink a logical volume
  • resizeStack (undocumented) – Grow or shrink a logical volume as well as the volume group and physical volume.
  • I am not sure how to include an image in comments (in regards to diskutil corestorage list) but my result looks similar, apart from the names, amounts of physical volumes, and in Revertible it says Yes (No Decryption Required) Is this what was expected? Also, if I do the command to resize the partition through diskutil corestorage resizeVolume do I have to resize both partitions to make space, or does it do that automatically? In the command diskutil corestorage resizeVolume, is the lvUUID|MountPoint|DiskIdentifier|DeviceNode the number next to Logical Volume in the list? Thanks
    – Cory
    Commented Jun 13, 2014 at 10:03
  • 1
    If the output looks similar then you should be fine. Revertible should be Yes, in case the drive is not encrypted using FileVault2 (so it's expected unless you enabled FileVault from the Security Tab in the system preferences). To make space for another partition (outside of the logical group) you will probably have to resize the whole Volume Group and therefore both partitions. It won't do it automatically. Use the "resizeStack" command which will resize both. The long alphanumeric identifier next to "Logical Volume Group", "Logical Volume" is the UUID you need for resize commands.
    – Chrisii
    Commented Jun 16, 2014 at 6:24
  • @Chrisii This was very, very helpful, yet I am still a bit uncertain how I could erase my OS X Test partition. I do not see my main partition in the output otherwise (I booted into Mavericks from the larger, main partition). What shall I do? Thanks! (It is lame, but I will the out put across multiple ensiung comments. Thanks for bearing with me.
    – László
    Commented Jun 30, 2014 at 15:32
  • d2m66h2j:~ laszlosandor$ diskutil corestorage list CoreStorage logical volume groups (1 found) | +-- Logical Volume Group B6308EC8-297D-44BD-9212-6BD867F6331B ========================================================= Name: OS X Test Status: Online Size: 29349998592 B (29.3 GB) Free Space: 204955648 B (205.0 MB) | +-< Physical Volume 3325F333-C8E3-46EE-9357-5E0C21A600D1 | ---------------------------------------------------- | Index: 0 | Disk: disk0s4 | Status: Online | Size: 29349998592 B (29.3 GB)
    – László
    Commented Jun 30, 2014 at 15:34
  • +-> Logical Volume Family E8CB0EB7-A2B7-48AA-AA13-5DE30867901B ---------------------------------------------------------- Encryption Status: Unlocked Encryption Type: None Conversion Status: NoConversion Conversion Direction: -none- Has Encrypted Extents: No Fully Secure: No Passphrase Required: No |
    – László
    Commented Jun 30, 2014 at 15:35

If your partition turned into Logical Volume Group (you can't resize or delete Yosemite partition), you can revert partition type with few command line.

Open Terminal type diskutil corestorage list Find Yosemite partition UUID string.

type diskutil corestorage revert <UUID>

Your Yosemite partition is now revert to default partition type. Now, you can resize or delete yosemite partition.

  • 6
    Thanks, this helped me. The actual command: diskutil corestorage revert <UUID> where <UUID> is the blue hightlighted uuid in the above example. Commented Sep 25, 2014 at 21:42
  • Why did Disk Utility automatically convert it to a format that it couldn't manipulate? Commented Jun 8, 2015 at 21:18
  • Pro tip: ensure your computer is plugged in while running @MarinovIván's command (my computer wouldn't do the reversion unless it was plugged in the whole time.)
    – user102656
    Commented Jun 11, 2016 at 7:49

Disable FileVault in System Preferences -> Security&Privacy, restart, try again. Worked for me!

  • 1
    I had to watch the progress using diskutil corestorage list. I could see Conversion Status: Converting and Conversion Direction: backward. So if this doesn't work, I'll run corestorage revert as others suggest. Thank You.
    – jrwren
    Commented Mar 13, 2015 at 23:29

Please ensure that you have both partitions formatted with a file system that Mac OS X supports online resizing for (i.e. for example HFS Extended Journaled).

  • 1
    This looks more like a comment than an answer... :-/
    – Potherca
    Commented Mar 22, 2015 at 13:37

Looking at the Used sizes in your Disk Utility, I think you don't have enough space to resize the partitions. it will fail if it doesn't have enough free space to move files around (partitioning is not virtual - it depends on data being in certain locations on the hardware).

Use something like Carbon Copy Cloner to make a disk image backup of the partitions, repartition the external as you desire, and copy back. Do NOT use block copy mode.

Virtual machines like Fusion make beta testing like this a lot easier.

  • I agree with you. However Resizing in Disk Utility only works on physical volumes and not logical volumes in a volume group. Non-destructive resizing always requires that enough free space is available.
    – Chrisii
    Commented Jun 10, 2014 at 11:48

For a start, you can go to "Startup Disk" under system preferences to start up into your old OS X from Yosemite. From there maybe you will be able to partition/fix however you like.

  • "Maybe"? Thats not much of an answer :-(
    – Potherca
    Commented Mar 22, 2015 at 13:37

Try this: highlight Macintosh HD and click "+" to add a new partition. Follow the screen to allow the new partition to be added. Do this to prove the OS would let you add a partition.

Now highlight the partition just aded and click "-" to delete. Do this to prove the OS would let you delete a partition. If both action were successful, you should be able to adjust the Macintosh HD to any size.


I have solved this after two days of searching around the Internet. I am using MacBook Pro 15" retina, with another partition having Windows 8 created by Boot Camp in Mac. The question, when I run disk utility I don't see the "draggable" corner of the hard disk which I need to resize. This is my solution, I will write down step by step:

  1. Turn off the FileVault encryption in the System Preferences → Security This took my Mac 3–4 hours to finish!

  2. Then restart in recovery mode by pressing Command + R during the restarting process.

  3. In the recovery mode, run Disk utility. Turn off the disk encryption which is at the file setting on the top bar. Now you will notice that your hard disk name might change.

  4. Restart again in OS X. Run Disk Utility. Now the "dragging" corner is available. Click on it and resize as you want. For me I reduced the Mac HD for some gigabyte which I will need for the Windows OS.

  5. Restart into Windows OS. Download the free software Minitool partition. It will allow you to merge unused space with your windows HD. Everything was smooth and my windows is still running nicely.


In my case, I had already disabled FileVault on my primary partition to allow Boot Camp Assistant to resize the primary partition to accommodate a BOOTCAMP partition, but after manually deleting the partition, Disk Utility couldn't (wouldn't?) resize the primary to max while it was mounted to filesystem root.

I rebooted to Internet Recovery Mode by pressing Command ⌘+Option ⌥+R and opened Disk Utility, which was able to resize the primary partition back to full capacity without difficulty.


In Disk Utility, select entire drive, then Partition tab. You can drag and resize it there.


in diskUtility select the entire volume ,partition. simply write the size of the volume you want to create in the field size and apply. you receive two volumes and you can partition again them...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .