3

After a reboot several strange issues come up from nothing. Suddenly all system directory lost their icons: Desktop, Home, Downloads, Pictures, Movies... have the normal folder icon. Even in Finder's sidebar. In console.app I noticed this when Finder opens:

09/06/14 16:17:44,722 Finder[250]: Could not find image named '357D167A-6053-47A6-BD22-B028736F98C1'.
09/06/14 16:22:14,810 Finder[250]: Could not find image named 'D54AFEF0-1EF4-43D6-8F3F-84A181AC04B2'.
09/06/14 16:22:14,810 Finder[250]: Could not find image named '357D167A-6053-47A6-BD22-B028736F98C1'.

Every time I open Alfred 2 preferences these are reset to default. Themes, workflows, everything is reset.

At last Safari won't connect to service hosted on localhost through https

Safari can't open the page because Safari can't establish a secure connection to the server. I tried:
  • rebooting
  • repairing permissions
  • resetting safari
  • reinstalling Alfred
  • deleting com.apple.finder.plist
  • removing every login item and launch agent

The problem persists and I don't know what causes this or how to fix it. Is there a way to restore the custom folders Finder shows for user default folders?

Here there is the log of the boot taken from console.app.

  • @Buscar웃 What do you mean? Finder? – Rnhmjoj Jun 9 '14 at 15:38
  • What I mean is, if you start in Safe mode or start as different user ? to check if your user is in trouble. – Ruskes Jun 9 '14 at 15:40
  • In safe mode the icons are back. – Rnhmjoj Jun 9 '14 at 15:50
  • 1
    So now we know you have a application causing it, and it is not a OS problem. I would guess it is Alfred, so disable/uninstall and try. – Ruskes Jun 9 '14 at 15:55
  • Ok, this is really weird. After the safe boot the Finder issue didn't appear even in normal mode. After another reboot the icons are gone once again. However I completely removed Alfred but the problem persists. – Rnhmjoj Jun 9 '14 at 16:08
1

try this in Terminal

mkdir ${TMPDIR}/com.apple.IconServices

This recreates the com.apple.IconServices directory, which apparently gets itself deleted from time to time.

  • Guess what? Today I turned the mac on and the icons disappeared again. – Rnhmjoj Jun 17 '14 at 17:01
  • Just made a clean install to 10.10 beta and after a reboot... same problem. It's obviously some program I have installed but I can't figure out which is. – Rnhmjoj Sep 13 '14 at 9:45
0

Ah yes, the disappearing icons trick. I had this happen a long while back, and it was pretty simple to fix. I deleted one file:

~/Library/Preferences/com.apple.finder.plist

Then rebooted and the problem was solved. I think what happens is something can cause the Finder preferences to get corrupted, so deleting the .plist will force a new file to be created upon the next reboot.

  • The first thing I tried. Nope, it does nothing. – Rnhmjoj Jun 9 '14 at 16:21
  • Interesting. Have you cleaned caches, and repaired permissions? – l'L'l Jun 9 '14 at 16:22
  • @l'Ll Yes, I have. – Rnhmjoj Jun 9 '14 at 16:24
  • Well it's pretty safe to say that something that is installed is causing the issue. You'll want to try and remember when it was exactly that problem started. Do you possibly have the SIMBL plugin installed (which colors the sidebar folders) or anything similar? – l'L'l Jun 9 '14 at 16:43
  • I made a clean install a few days ago. The system is pretty empty. I have no SIMBL plugins or installed any software recently. – Rnhmjoj Jun 9 '14 at 16:49
0

I've had success with: http://samguichelaar.com/FixIcon.zip
A small app that deletes icon caches, resets permissions and reboots.

  • Fortunately the problem disappeared some months ago but I still have no clues on whats was going on. Thanks anyway, maybe it could of help for someone else. – Rnhmjoj Jun 23 '15 at 17:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .