0

Updated to Mavericks: Now get following message for specific apps in Applications Folder: "you can't use this version of the application "DVD Player" with this version of OS X." It then lists the version of the app that I currently have. This has affected 16 Apps on my iMac. Some of them (Safari, Photo Booth) have updated version on my desktop that run. With all of the other affected apps, do I have to purchase updated versions? Also, how do I delete the non-functioning versions from my Applications folder?

  • 1
    sounds like you should reinstall mavericks, that is easy if you saved the copy of the installer. Before that just run the disk utility permissions repair to see if it helps – Ruskes Jun 8 '14 at 17:05
1

I would reinstall Mavericks.

You could run the Disk Utility and repair the Permissions before that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .