1

A follow up to my earlier question about the Mavericks installation from an SD Card. I am running this in Terminal:

mv Packages /Volumes/OS\ X\ Base\ System\ 2/System/Installation

The response is: Read-only file system. In Diskutil, the SD Card isn't greyed out. According to this, I have to copy data from the Install ESD image to the SD Card to make it work.

But unfortunately, Terminal gives me this error. I also tried changing the file permissions with chmod en chown, which resulted in no change.

  • Lots of SD cards and SD card adapters have a physical write locking switch. Is yours enabled? – Jason Salaz Jun 7 '14 at 20:15
  • My SD card is not locked, as I had executed the createinstallmedia script from OS X Installer, after which this Read-only file system error has occured. – user3710669 Jun 7 '14 at 20:19
  • I also have tried mount -o remount,rw /dev/disk2s2 but that results in unknown special file or file system and I am sure that the drive is correct – user3710669 Jun 7 '14 at 20:31
  • Disk Utility mentions that the SD Card and the partition are Writable. – user3710669 Jun 7 '14 at 20:37
  • 1
    @user3710669 How is the card formatted and what's it's partition scheme? – njboot Jun 8 '14 at 0:37
1

I had a similar problem after installing Windows 10 IoT for raspberry pi on an sd card and it managed to make the card and file have no +w on directory/file. This was mistake number one as it turns out me managing to write this to a card on a Mac was never going to work on the pi. So the problem remained of how to reformat, as erase in disk utility would not work and no use of chmod would change the bits. Tried to change on an ubuntu box with the same problem "Read-only file system".

The only (hacky) way I managed to do reformat the card was to put it in a camera and reformat there - and bingo - done.

I'm sure there is a legit way to do this (maybe on windoze but I don't have one of them), but the camera trick worked like a charm. It was a fujifilm x100s in case not all cameras can manage it.

| improve this answer | |
  • THANK YOU! I tried resetting the SMC, NVRAM, tried running all the maintenance scripts, change permissions through command line, play with the lock switch to land in the middle, diagnostics tests, safe mode and I don't even remember what else but for whatever reason this worked! I was really getting desperate. Thanks! – George Dec 1 '16 at 20:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .