1

I have a late 2012 mac mini running OSX 10.9.3 and I'm curious if there is a setting that needs to be changed or if this is some sort of bug. I'm working with two monitors; one plugged into HDMI and the other using the display port with a VGA adapter.

Regardless of which application I am using on my VGA monitor, when I switch to the HDMI monitor by clicking into an application, TextWrangler comes to the front. I've searched through system settings and TextWrangler settings, but I couldn't find anything to fix this problem.

This is incredibly irritating and I'd appreciate any help.

  • If you quit TextWrangler does it work normally? – 0942v8653 Jun 6 '14 at 18:34
  • Yes, this problem seems to only happen with TextWrangler. – nickg Jun 6 '14 at 18:37
  • Well now that I've quit and re-opened the program, it stopped coming to the front. I don't know what could have caused it, but it's back to normal now. – nickg Jun 6 '14 at 18:40
  • So killing the application and re-opening did the trick? You should consider writing this as answer, maybe others have the same issue with an application popping up. – Rob Jun 6 '14 at 18:42
1

Quitting TextWrangler and re-opening it fixed the problem.

0

If you are using the command line tools where you open it with

edit yourfile.txt

Then there is a flag you can use to open it in the background. You can defualt this via an alias in your .bash_profile or .cshrc

The flag is:

edit -b

The .bash_profle alias would look like:

alias edit='edit -b'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .