2

I just unwrapped a MacBook Pro (OSX 10.9.3). I used the Migration Assistant to bring things over from my old mbp, and most everything seems to be working except something very important: the Terminal app. Well, I actually use iTerm, but they both exhibit the same symptoms: when I launch the app, the window flashes for (maybe) a few milliseconds, then disappears.

It's not hiding or minimized. The app is open (in the toolbar, etc.), but no windows will appear. I even tried running an executable bash shell script (*.command), but nothing really appeared and the script apparently didn't execute.

This is a very fundamental problem. Is it back to the Apple store? The only other weirdness I've noticed is that the setup when I first booted it was kind-of buggy, and I had to hard-reset it (which really surprised me). However, after I rebooted, it worked fine, and I got it set up as usual.

Edit Here is what the console says when I launch Terminal.app:

6/6/14 6:46:26.071 AM login[1450]: USER_PROCESS: 1450 tty??
6/6/14 6:46:26.072 AM login[1450]: DEAD_PROCESS: 1450 tty??
6/6/14 6:46:26.076 AM com.apple.launchd.peruser.501[173]: (cx.pow.powd[1448]) Exited with code: 8
6/6/14 6:46:26.076 AM com.apple.launchd.peruser.501[173]: (cx.pow.powd) Throttling respawn: Will start in 10 seconds
6/6/14 6:46:36.241 AM login[1454]: USER_PROCESS: 1454 tty??
6/6/14 6:46:36.243 AM login[1454]: DEAD_PROCESS: 1454 tty??
6/6/14 6:46:36.247 AM com.apple.launchd.peruser.501[173]: (cx.pow.powd[1452]) Exited with code: 8
6/6/14 6:46:36.247 AM com.apple.launchd.peruser.501[173]: (cx.pow.powd) Throttling respawn: Will start in 10 seconds

It keeps repeating similar messages every ten seconds.

Edit 2 If, in my Terminal.app preferences change "Shells open with:" to "Command (absolute path)," which is "/usr/local/bin/bash," a window pops up that says.

[Command not found: /usr/local/bin/bash]

[Could not create a new process and open a pseudo-tty.]
  • Can you look in the Console and tell us why. – Ruskes Jun 6 '14 at 7:44
  • did you check the terminal preferences – Ruskes Jun 6 '14 at 7:48
  • @Buscar웃, I'll update my question with the console output. It looks like all my terminal preferences are default. Anything in particular you're looking for? – Rico Picone Jun 6 '14 at 13:48
3

Well can I ask you what default login shell is? mine is /usr/local/bin/bash from Homebrew, and if I move my stuff from Time machine to a new computer Homebrew is there but for some reason it is hosed, so I need to change the login shell, remove Homebrew, reinstall XCode, reinstall Homebrew, reinstall /usr/local/bin/bash and change my default login shell again. I might be wrong on your special instance, but it is something worth considering. In general Migration Assistant works for your data and all the "normal" stuff and Apps people have, but any developer/Unix stuff gets broken (or so it is my experience over dozens of migrations).

PS to change your default login shell go to the Preferences Panel (the thing with the cogwheels icon), Users and Group, unlock if needs be, right click on yourself -- the option of 'Advanced options' will come up, click that and change your login shell. Save, log out and you're set.

  • Thanks for the info. This seems like good advice that I will follow. How do I determine/change my default login shell without opening a terminal? I used Homebrew to set up everything on my old mbp, so it seems like this would help. See the edits in my question. – Rico Picone Jun 6 '14 at 14:07
  • If I change "Shells open with" to /bin/bash, I actually get a window with a couple errors, and it seems to work just fine. I think I'll follow your advice and update how it goes. Thanks! – Rico Picone Jun 6 '14 at 14:16
  • I added some info on how to change the login shell – user1256923 Jun 6 '14 at 14:22
  • Thanks. I accepted your answer, but I don't yet have enough rep to upvote. As soon as I do, I will. Thanks! – Rico Picone Jun 6 '14 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .