8

I tried plugging in my apple headphone's jack into the socket, but I wasn't able to. Barely 70% of it goes in and the rest doesn't. There is no red-light coming out of the socket, but in the 'Sound' settings panel, the output device is 'Digital Out' -> 'Optical Digital Out Port'.

There is no sound emitted from the speakers and the sound icon in the taskbar is grayed out.

I managed to turn on/off the Analog to Digital switch inside the socket. The other (turn the switch 90º clockwise) solution, I haven't tried yet. The weirdest thing is that there's nothing stuck inside the socket! I looked with a led flashlight, but for some reason, this jack won't go in.

Is this a hardware issue?! What are the next steps?

--Edit--

Adding the picture of the jack and socket and another for the 'Red Light of Death'.

Jack not wanting to fit in the socket Another picture of the 'Red Light of Death'

  • 1
    have you tried pushing it harder? It don't suppose t one that hard. – Laszlo Jun 5 '14 at 12:18
  • 3
    first I would check if something is stuck in there – Ruskes Jun 5 '14 at 14:24
  • Shine a flashlight into the jack and see if there's anything in there preventing full insertion. If not, use a paperclip to push on each contact inside to make sure they move freely with a little force. Examine the headphone plug to make sure it is round and hasn't been damaged. Try it in another device with a headphone jack, and try a different headphone in this jack. If none of this works, report back and tell use what you found at each step. – Adam Davis Jun 5 '14 at 15:49
  • @AdamDavis already used a source of light to check for anything blocking the socket (there was nothing), I used a pair of tweezers and exerted a little force (it seemed fine and I was able to push a bit that light source at the end), The earphones I'm using work perfectly on my iphone. The strange thing is that even though the headphones are not fully plugged in, the mac is able to recognize them and the sound icon is not grayed out when they're in. You should also know that when I restart the OS, I can hear the startup sound through the speakers. – Bassem Jun 5 '14 at 19:40
  • 1
    For all those suffering and as a workaround, you can use AirFoil to stream system output to your iOS device through WiFi.. – Bassem Jun 7 '14 at 19:53
12
+100

When you insert the headphone into the socket, it makes connections internally against a number of poles which connect to the different rings on the jack end (left audio, right, mic, ground, data etc..). These are essentially tiny spring loaded contacts which the jack must push aside when inserting, that then rely on sprung pressure to maintain a permanent connection to the ring on the jack. Here are a couple of pictures, a diagram, and a photo or a replacement part that shows one of the poles:

Diagram of socket poles

Photo of replacement socket

These poles can jam, get stuck, fail etc etc. Usually a vigorous insertion is enough to free them, but this is relying on the chamfered edge of the jack to transfer vertical motion into a horizontal movement of the pole. You could use something slimmer than your jack, and insert (carefully, ensuring you don't insert it too far) before applying sideways pressure directly to the poles to try to get more energy into making them move.

  • Even though the problem is not solved by the above, but it is definitely a physical socket fault. – Bassem Jun 10 '14 at 12:38
4

Ok what seems to me is you have to separate issues.

  • The reason for the headphone jack not going in completely maybe due to a jammed pole. the possible solution for which is either trying to forcefully push it in, or take it to Apple care.

  • The reason for the red light being show is cause the mac is assuming that there is a Optical Digital Out connected, which will be fixed automatically once you insert the jack properly. This I know as I had faced the same issue of the Red light flashing and I had consulted and Apple Tech support and he answered this to me.

4

I did this the old fashioned way -- took my 3.5mm connector and hammered it in, using a literal hammer. After doing so, some white dust came out of the port (which I vacuumed up). I'm presuming something was stuck in there? Either way, everything is working now, so +1 for the brute force solution here (at least for me).

  • Had to upvote you for the hammer :D – Zoltán Mar 16 '17 at 20:09
  • Not a joke. Headphone plug wouldn't go all the way in. Shone a light in and it looked like there was a little plastic ball in there. There was, probably a silica gel ball, hard plastic couldn't pry it out with a pin. Closed the macbook, set it up on it's edge, put a medium nail in the jack, tapped it with a hammer. Flipped it over and tapped the edge with my fingers, the broken plastic fell out. No damage, works great now. – reads0520 Dec 29 '18 at 17:35
1

The jack is designed for both types of connection - thru a metal wire (analog mode) or via an optic fibre (optical mode) for better performance.

  1. Try by removing the current optical PLIST file that is used. Execute the following command in Terminal App: sudo rm -rfv ~/Library/Preferences/com.apple.audio.Au­dioMIDISetup.plist
  2. Try unplugging and replugging a headphone plug into the port several times. There is a tiny sensor inside the port that determines whether the port operates in optical or analog mode. Plugging something analog in is supposed to trigger the sensor and restore the analog signal. - I used tooth pick.

Both ways have helped me fix such issue.

  • Unfortunately that didn't work for me. The problem is that I have a small plastic ball that is stuck in the jack continuously pressing against the digital out switch. So far, after all the online research, I still don't know of any method to override / disable this switch. – Bassem Aug 9 '15 at 1:14
  • Then I can recommend to carefully place a small sticky tape(or may be gum) on the very top of a tooth pick and try catching the little peace that is there, so you can pull it out. In order to help the ball to fall out, you may need to place the laptop on a specific angle. – Anton Todorov Aug 9 '15 at 18:10
  • Thanks @Anton but I have exploited 'every' possible way to try to get that ball out, it fits perfectly in the jack as if it was designed to. I think the jack is ruined and I just made peace with that fact :D – Bassem Aug 9 '15 at 20:40
  • Well, then unfortunately there is nothing else I may help with, @BassemDy :( I can suggest you to buy a new jack out of eBay and replace it so you can get back your functionality. – Anton Todorov Aug 10 '15 at 11:57
1

For me, it was a stupid silica gel ball that fell out of a silica gel packet in my laptop case. The ball can be crushed (like glass) and removed in pieces if it's stuck in there. I was able to crush the ball with tweezers and blow the glass dust out.

  • Same. Silica ball. For those finding this question who's headphone plug just won't go all the way in even with force, shine a flashlight in the jack, and if it looks like there's a little plastic ball in there, there probably is. Seems extreme, but I closed my macbook, set it up on it's edge, put a medium sized nail in the jack, and gave it a tap with a hammer. Flipped the macbook over and gave it a couple taps with my fingers on the edge and the broken plastic fell out of the jack. No damage, listening to music and happy now :) – reads0520 Dec 29 '18 at 17:31
1

I had the same problem, i had a stuck micro switch that was causing my internal speakers to stop work. i tried everything to release the stuck micro switch, So how i fixed the freed the stuck switch, was with good old WD40, Frist i powered down the macbook pro, then i squirted some WD40 into the headphone socket and then in pushed in a 3.5mm jack a few times in and out, waited about 30 mins and then when i powered back up the laptop, BINGO...my internal speakers where working, so the WD40 released the stuck micro switch. some time you have to think out side the box to fix problems.

The 3.5mm socked is sealed so no WD40 when into the laptop.

0

I had the same issue on my MacBook Pro 15" 2015 for a long time. The built-in speakers initially were working fine up to the point when I decided to stick my headphones in the socket. I wasn't able to do that as the jack was not going in to its full length, just like on the OP's picture above. While figuring it out I was able to put the jack briefly in a position where the headphones would play audio. As soon as I got the jack out though the socket started glowing red and the built-in speakers became off.

I tried a lot of different advices trying to clean a supposedly stuck pin in the socket but to no avail. The red light kept coming out through the lens at bottom of the socket and it was clear there is nothing stuck in there.

What I did eventually was pushing a jack in there really hard while twirling it a little. Not long after I heard some crunching sounds of what I think might've been the lens. I shook it and this is what came out of the socket.

enter image description here

I'm pretty sure it's not some kind of a candy as it is not sweet at all :). It looks like pieces of what might have been the actual lens glass or some kind of intermediary glass.

Anyway, I inserted a toothpick in the socket and tried to get all this crunchy stuff out. As I was doing that I eventually reached deeper and at some point it got unstuck. My built-in speakers went on just fine.

Eventually I was able to insert the jack all the way into the socket. When I take it out my built-in speakers go on. I still get no sound through the actual headphones since when the jack is in, the socket lights up the red light. Probably some stuff is still there and prevents a proper contact with the jack. I'm not bothered by this much as by this time I'm used to my bluetooth headphones. Hope this helps. Cheers to @Kevin Ushey for showing us what's possible :)

0

My jack wouldn't go all the way in, and nothing foreign blocking it. Decided to go with the push it really hard method, which yielded a crunching sound and white powder coming out, which I made the mistake of sucking out! Duh! So ended up with gritty stuff in my mouth, which I had to spit and rinse out. However, a bit more grinding with a tweezer, removed the blockage, and the rest of the powder and now I am in business. Thanks to the brave ones who tried it first!

You must log in to answer this question.

protected by Community Jun 16 '18 at 13:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .