running OS X Server (Mavericks) I am trying to use file sharing. When I create a Folder and select that for sharing and add users they get read & write access, but when I take a closer look via the Server App under Storage, they all have no "Delete" permission on folders inside the share.

This happens on new folders I share as well as with users I newly create. Any ideas? Screenshot

  • What user are you authenticating to the server as when you open Server.app?
    – Matt
    Jun 8 '14 at 2:37
  • With the admin user "server" Jun 8 '14 at 9:35
  1. Select the containing folder in Server.app, then Edit Permissions….
  2. Click the gear icon at the bottom of the sheet, then select Make Inherited Entries Explicit.
  3. Change the permissions as you desire (the users should no longer be greyed out), then click OK.
  4. With the containing folder still selected, click the gear icon at the bottom of the window and click Propagate Permissions….
  5. Select all the option boxes, then click OK.
  • I haven't had a chance to try logging in with one of the users, but at least in theory, via the info-pane this seems to apply the correct permission to sub-folders. Jun 10 '14 at 20:54
  • However, this still has to be done for every new share. I wonder, is this default behavior, that if I set a user to read&write for a share, that he can't delete folders within that share? Or is 'something' messed up on the server? Jun 10 '14 at 21:13
  • @Kevin It depends where your shares are located, but based on your description, yes, but only once for each share. If your new shares are within a single folder, do this to that folder and new shares will inherit these permissions and not require this procedure.
    – grg
    Jun 12 '14 at 14:44

Have you tried repairing permissions?

To do so,

  1. Start Disk Utilities
  2. Select the partition in question (not the volume)
  3. On the first-aid tab, click "repair disk permissions"

When I've had a similar problem, this approach has solved it.

enter image description here

Good Luck

  • Tried, didn't help Jun 8 '14 at 9:35
  • Repairing permissions fixes permissions on the System folder and related support folders but will not affect custom ACL's setup for file sharing or home folder permissions.
    – mifi79
    Jun 10 '14 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .