2

The environment i have setup consists of an OSX Server, running file sharing and VPN.

The file share is accessible from the local network on both windows or OSX machines, and OSX machines have no problem connecting to the server via VPN when on a remote network.

However, i can't seem be to able to set the VPN/File share up via a windows machine that is not on the local network, can anyone advise further as to how I would allow windows machines to connect to the osx servers file share/vpn from a remote network?

Thanks!

2
  1. Add this to your registry: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\PolicyAgent] "AssumeUDPEncapsulationContextOnSendRule"=dword:00000002

  2. Open secpol.msc (click start > search for secpol.msc)

    • Local Policies > Security Options
    • Network Security : LAN Manager Auth Level…
    • Set to: Send LM & NTLMv2 - UseNTLMv2…

And

  • Network Security : Minimum session security… clients
  • uncheck "Require 128-bit encryption"

    1. Restart PC

    2. Create VPN Connection on Windows 7

  • Host Name: (server IP or yourhost.name.com)

  • PPP Settings : Enable LCP (only)
  • Type: L2TP/IPSec
  • Pre-shared key : yoursharedsecret
  • Data encryption : Optional encryption
  • Allow CHAO and CHAPv2

    1. Router on server-side must allow VPN Passthrough and forward ports: 50, 51, 500, 548, 1701, 1723, 4500 to the server box. Also, do not filter anonymous internet requests, multicast or NAT Redirection but enable SPI Firewall.
  • Thanks Echeola. Just to clarify, the Reservation and Port forwarding has been set up - and OSX can connect via VPN perfectly from outside the local network - It's just windows machines I'm having trouble with – fish_r Jun 4 '14 at 17:09
  • Ah, Apologies. The router that's being used is: TP-Link 150M Model: TL-WR740N / TL-WR740ND Unfortunately we're stuck with this router as it's tied with our Service Provider – fish_r Jun 4 '14 at 17:53
0

I've been struggling with this too for a while and finally make it work.

At OSX VPN Service, I changed the L2TP for LT2P & PPTP, and that made the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .