1

I've made a partition on my hard drive, so I currently have Macintosh HD (call it 1) and Macintosh HD 2 (call it 2).

I downloaded the Yosemite installer with my Mavericks install on 1, then ran it and selected 2 as the disk to install on. It worked fairly well and I'm running Yosemite without any problems.

But tonight I tried to switch over to Mavericks, so I rebooted and held down option. When the list came up, it contained recovery volumes for OS X 10.9 and 10.10. It had Macintosh HD 2 on it (my Yosemite partition), but not Macintosh HD. Instead of my Mavericks partition, it showed an 'Install OS X' volume. Selecting this shows the Apple logo with a progress bar under it, then boots into Yosemite.

I can view /Volumes/Macintosh\ HD/ and see that everything is still there.

How can I boot back into my Mavericks install?

closed as off-topic by Max Ried, Ruskes, Matthieu Riegler, grg, Rob Jun 5 '14 at 6:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

4

I also asked on the developer forums and got an answer there (iOS/OS X dev account required to view).

The solution was to boot into a recovery partition ( + R), and change the boot disk from the Apple menu. It needed to be changed to my Mavericks install instead of my Yosemite install.

-1

You can also boot into Yosemite > System Prefs > Startup Disk > Select Mavericks and tap Restart.

Not the answer you're looking for? Browse other questions tagged .