0

In the Find my Friends app, some of the entries in there no longer show the portrait from that person's entry in Contacts. The email address is displayed instead. I would like to have the portrait back (or initials where there is no portrait).

This appears to have been happening for some people since 2011. Further threads 2012, 2013 and 2014.

Advice from those threads include:

  • Ensure Settings -> Privacy -> Contacts -> Find Friends is On.
  • Add the email address to the Contacts entry for that person.
  • Restarting app and/or phone.
  • Deleting the app and reinstalling.

I have tried all of the above, except deleting the app. I am hesitant to do this, as this will require me to pester all of my friends again upon reinstall.

It all used to be fine, and then one day it wasn't. I always had the correct email address in Contacts. The privacy permission was always correct. I don't know what changed. The latest person I've added has their portrait fine, but not so for the others. Even "my" Find my Friends details are "unknown".

Is there a solution that will fix this short of deleting and reinstalling? I'll do that if there's no other recourse :(

1
  • I still get this with iOS 11, but it's flaky. Sometimes it shows names, sometimes email addresses. Just now it was showing addresses, and I found this page, but then I re-launched the app and now it shows names. – Tom Harrington Nov 13 '17 at 18:01
1

I suffered from the email-address-instead-of-name problem after replacing my phone's local contact info with a sync copy from my gmail account. this seemed to work for me (ios7):

  1. click on the contact name in the 'find my friends' window
  2. click the 'contact' button at top left
  3. click 'add to existing contact'
  4. select the relevant person in your contacts list; this will seem to add a duplicate email address, and you might want to clean that up later

restart Find My Friends... is now showing names (for me at least)... good luck.

0
0

This problem was solved for me after logically looking into where the email address came from. I have several groups of contacts. One of the groups is auto-populated via an Exchange server with used email addresses separate from the contact with the same email address. Removing that auto-generated contact entry and disabling that contacts group did the trick for me! Pictures and contact details are correct again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .