My iPod (4g iOS 6.1.6) is stuck in soft DFU mode because I quit out of redsn0w too early. Then I also used an app to exit recovery mode and now it's in soft DFU mode. I had to use the DFU IPSW in order to put my device in DFU mode in the first place.

When I attempt to restore it in iTunes, after the "extracting software" step, the software says "preparing iPod for restore". After the 1-2 minutes, pass the boot logo does not show up and iTunes says "The iPod (iPod) could not be restored. An unknown error occurred (1601)."

I'm just going to try and let my iPod die and then reboot it. Any alternative suggestions on how to regain control of the device?

  • What happens if you plug it into iTunes and restore?
    – bmike
    Jun 3, 2014 at 18:45
  • It extracts the ipsw, but when it says preparing device, my iPod doesn't show the apple logo. After about 1 minute it says error 1600 I believe.
    – Twiztedx
    Jun 3, 2014 at 18:48
  • Definitely run the restore and post the exact error message or a snippet from the restore log. It could be something you can fix sooner than waiting several days (or however long the battery lasts in that state).
    – bmike
    Jun 3, 2014 at 18:50
  • After extracting software, it says "preparing ipod for restore". After the 1-2 minutes pass the boot logo does not show up it says "The iPod (iPod) could not be restored. An unknown error occurred (1601).
    – Twiztedx
    Jun 3, 2014 at 19:01

3 Answers 3


Use ReiBoot app to push the phone out of recovery mode cycle. I had the same problem and only one that app solved it. I tried going into DFU mode and without DFU mode, using .ipsw files to restore old and new iOS version, and none worked. I installed ReiBoot and in 5 minutes I solved the problem. Just install the app for mac (I do not know if it works for windows) and plug the iPhone in the computer. Open the ReiBoot and push the phone out of recovery mode cycle. VOILA! This was the only thing that worked for me. Nothing else worked. I tried different USB ports, different USB cables, nothing else worked, literally.


Found the weird but working way,

  1. On another machine, connect i-device to iTunes. It will be detected as if in "Recovery Mode"

  2. Download IPSW for your device that is still signed

  3. Download Redsn0w, Go to extras -> even more extras -> DFU IPSW. Open original IPSW, let the tool create a patched IPCW

  4. Back to iTunes - push ALT and press the "Restore phone" button. In the undocumented menu, open patched IPSW.

    You'll go Soft DFU -> Recovery -> DFU

  5. Back to Redsn0w. Extras -> Just boot


I found this on apple support communities

Connect the device to iTunes, confirm that the device is in Recovery Mode. If it's not in Recovery Mode, put it into Recovery Mode. Restore and wait for the error. When prompted, click OK. Close and reopen iTunes while the device remains connected. The device should now be recognized in Recovery Mode again. Try to restore again.

Full thread

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .