I just installed OS X 10.10 Yosemite (but this problem exists for any other OS with applications that run on your current Mac OS) and, because I have a Carbon Copy Clone of my old Mavericks installation on another hard drive installed on this Macbook, it shows applications from other installations mounted from the other hard drive.

Expecting the Terminal to work just as in Mavericks, how would I remove/exclude applications from a different installation from the 'open with' menu?

closed as off-topic by bmike Jul 30 '14 at 16:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • As long as this isn't really about how Yosemite runs, we're happy to host it since the problem of eliminating other OS apps from spotlight and Open With is a general problem to OS X and not dependent on the version. See meta.apple.stackexchange.com/questions/1712/… for details – bmike Jun 3 '14 at 13:32
  • Thank you. Now just have to settle and wait for some solutions. :) – Sander Schaeffer Jun 3 '14 at 13:49
  • Excluding that directory from spotlight will work in the short term, however, when you cross boot you'll find you want that directory indexed so the real solution will be to not mount multiple copies of the app at the same time. – bmike Jun 3 '14 at 13:52
  • But that will not be an option since I have to dynamically be able to copy files over from a different installation. :) But I'll keep it in mind. Thanks! – Sander Schaeffer Jun 3 '14 at 14:01

Does excluding the other Applications folder from Spotlight fix the problem?

In System Preference:

Spotlight System Prefs Screen Shot

After you've added the folder in Spotlight, you'll can refresh the "Open with..." list by running this command in Terminal:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fra‌​mework/Support/lsregister -kill -r -domain local -domain system -domain user
  • Well if that would work, that would be a hell of a simple solution. However, I just added the other application folder and rebooting my Mac, after this comment. I will report back ASAP with updates. Thank you! – Sander Schaeffer Jun 3 '14 at 13:53
  • Please add "After you've added the folder in Spotlight, simply run this command in Terminal '/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user' to refresh the 'Open with' list". - To your answer. The list should be refreshed in order to exclude already listed items. By that Terminal command you can simply refresh the 'open with' list and let it be rebuild. Thanks for your suggestion, as it was indeed (a part) of the solution! – Sander Schaeffer Jun 3 '14 at 14:00

Not the answer you're looking for? Browse other questions tagged .