12

I messed up the settings for the clamshell display mode on my MacBook Pro. I can't get my external display to work when I close my laptop. I can get all other modes working (standard mirroring and shared desktop) except for clamshell.

I've tried using defaults to remove com.apple.windowserver, but that hasn't helped.

2
  • where did you do the messing up ?
    – Ruskes
    Jun 3, 2014 at 11:35
  • I clicked the wrong resolution, one it is supposed to work on, but doesn't. a
    – CyberSkull
    Jun 3, 2014 at 12:49

9 Answers 9

7

Neither of the above two answers has solved the problem. Maybe I can move the ball forward a couple of inches ...

I, too, clicked on the wrong resolution for my external monitor and now I can only use the monitor in "Mirror Displays" mode. When in separate mode, the external monitor is black except for a message saying "DVI NO SIGNAL". I cannot see the System Preferences > Displays control dialog for that monitor because it's on the black screen. When I return to Mirror Displays mode, I can see that the wrong resolution is set and when I set the proper one, I get both monitors work -- but ONLY if I stay in Mirror Displays mode.

This sounds like exactly the problem that @CyberSkull reported, same cause, same results.

I can verify that Colorsync Utility.app does nothing for resolution, only color profile, and my profile is likewise set to Factory Default.

Similarly, the answer about hmscreen is about Arrangement, not Resolution. I looked at the doc for hmscreen and it confirms that it deals with ScreenIDs, screen positions, and which screen is the main screen, not resolution. I'm afraid to try it to set the black external monitor to be my main screen, and that seems to be the only experiment it might be useful for.

Finally, I found a solution that worked for me! In another Ask Different question, "change screen resolution with AppleScript", more than one AppleScript solution was offered (which I didn't try) AND @user332214 posted a link to a utility developed at the University of Utah, Display Manager which worked for me.

Display Manager supposedly has a GUI interface available, but I couldn't find where it had been installed to invoke it, so I used the command line interface. Once it was installed, the command line:

display_manager.py res 1920 1200 ext0

successfully changed my external monitor to 1920x1200 resolution, my usual, from the erroneous 1920x1080 that I had accidentally set and which resulted in a black screen except in Mirror Displays mode.

It works.

1
  • You are right, it works and must be marked as solution
    – mulya
    Apr 8, 2021 at 10:34
3

I tried other suggested solutions but removing com.apple.windowserver.displays.plist to reset back to defaults was the only thing that worked for me:

cd /Library/Preferences
sudo cp com.apple.windowserver.displays.plist ~/Desktop
sudo rm com.apple.windowserver.displays.plist
nvram -c
sudo shutdown -r now
  • Make a copy of the file, just in case (can omit)
  • Remove the display preferences file
  • Clear nonvolatile random-access memory
  • Reboot
1
  • Thanks! This was the only thing working on my M2 MacBook Pro
    – m9t
    Jan 4 at 21:37
2

I clicked on the wrong unsupported resolution for my external display while my macbook was closed.

After trying almost all the solution above (unfortunately none of them worked) I tried to do an easy thing:

  1. Start a videocall on your Mac.
  2. Share your screen and connect with another device.
  3. Close your laptop while moving the mouse and you should be able to see the shared screen on your device (even if the monitor still has the no signal error).
  4. At this point you can just go to Settings > Displays and change the monitor's resolution.
1

Open the Colorsync Utility.app in your Utility folder.

Click on your external display.

Set the profile to Factory settings.

1
  • It is set to factory.
    – CyberSkull
    Jun 3, 2014 at 12:51
1

I also messed up my settings and couldn't rearrange since it wasn#T displayed anymore. So I downloaded hmscreen, put it in the Applications folder and used it to reset:

  1. get the screen Id: /Applications/hmscreens -info
  2. set the arrangement: /Applications/hmscreens -setMainID [YOURDISPLAYID] -othersStartingPosition left

http://www.hamsoftengineering.com/codeSharing/hmscreens/hmscreens.html

0
0

I reset everything such as SMC, NVRAM etc but somehow after resetting I did one more thing that magically fixed it.

I used gSwitch and before plugging into the monitor I force integrated graphics card. Once plugged in, the switch will notify that mac force to discreet graphics card and somehow that fixed it but at a very low resolution.

Do it again, somehow the resolution goes back to the highest resolution again. I have no idea what happened but at least I got it fixed.

0

I messed up external display on MBP (black screen with beachball on ext + spinning beachball on main w/empty desktop) by selecting some obviously unsupported external monitor resolution via RDM app. DisplayManager.py unfortunately didn't work for me, as the external display wasn't even recognized.

Solution: start the Mac in safe mode, launch RDM, select desired resolutions, reboot to normal. :)

I do recommend RDM btw: https://github.com/avibrazil/RDM

0

If you have Screen Sharing enabled you can connect from another machine and should be able to access the un-displayable window.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Mar 24, 2022 at 10:58
0

Problem Statement

I had a similar issue when I changed my external display refresh rate from 60 Herts to 24 Herts as a quick test. At this point my external monitor remained black and I could not revert the settings.

TLDR

Use a Zoom meeting to share your external monitor to a second device and revert your settings that caused the problem.

Attempted fixes

I attempted the fixes posted above with now success.

  • ColorSync Utility set to factory settings did nothing for me.
  • Change screen resolution with applescript and referencing screenresolution was promising, but with my Mac version of 10.15.7 I kept getting errors that the mode was not available on my display, even though the setting is in the list when running screenresolution list
  • The various other items recommended in this thread didn't work because of the version of my OS 10.15.7 was not compatible with the tools due to my OS being older or the utility not being maintained.

Solution

The solution posted by kiwi didn't give me the exact details of the solution, but it lead me in the right path.

  1. Have Zoom installed your problem system, as well as a separate machine you can join the meeting on. (In my case I used my iPhone to join the meeting)
  2. Start a Zoom meeting on your problematic system.
  3. Share the link to join the meeting by selecting Participants -> Copy Invite Link.
  4. On your other computer (or mobile device), join the meeting.
  5. On your problematic system select the Share Screen option, and select the external monitor.
  6. From here you should now be able to view the screen on your second device as you revert the changes that caused the issue in the first place.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .