1

I messed up the settings for the clamshell display mode on my MacBook Pro. I can't get my external display to work when I close my laptop. I can get all other modes working (standard mirroring and shared desktop) except for clamshell.

I've tried using defaults to remove com.apple.windowserver, but that hasn't helped.

  • where did you do the messing up ? – Ruskes Jun 3 '14 at 11:35
  • I clicked the wrong resolution, one it is supposed to work on, but doesn't. a – CyberSkull Jun 3 '14 at 12:49
1

Open the Colorsync Utility.app in your Utility folder.

Click on your external display.

Set the profile to Factory settings.

  • It is set to factory. – CyberSkull Jun 3 '14 at 12:51
1

I also messed up my settings and couldn't rearrange since it wasn#T displayed anymore. So I downloaded hmscreen, put it in the Applications folder and used it to reset:

  1. get the screen Id: /Applications/hmscreens -info
  2. set the arrangement: /Applications/hmscreens -setMainID [YOURDISPLAYID] -othersStartingPosition left

http://www.hamsoftengineering.com/codeSharing/hmscreens/hmscreens.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .