2

I am trying to login into my work computer (Win7) which is in a private network through the Remote Desktop Client (RDC) after connecting through VPN. The VPN gets connected but the RDC does not. It tells me that the remote computer might not be connected or switched on, both of which are not true. The VPN is of Cisco IPSec type. I have tried changing the DNS of the VPN but it doesnt help. I am running OSX 10.9.3.Any solutions?

  • Having a similar issue. I can connect to VPN, but not to my workstation, using Mac with El Capitan, but had issue with Yosemite, as well. Workstation is Windows 7. I was able to connect using the same laptop, with Windows 7, via Bootcamp. I can also connect with my iPhone, just not the Mac. Any tips would help. Will create new thread if recommended. Thanks. – user180755 Apr 22 '16 at 20:32
  • I had to remove Windows firewall to get the VPN to work. – shunyo Apr 24 '16 at 3:26
2

I do this all the time and more often than not it is a subtle configuration issue on the PC side.

But first (once your VPN is active) open up terminal and ping one of your servers, network devices, workstations or a printer by IP address. One that you know will respond to a ping when you are AT work (EG no firewalls or stealth mode)

Once you have verified that you know that connectivity is there you want to verify that RDP works from one PC to another INSIDE your network. EG can you RDP in from someone else's PC to the PC you want to get to?

This should start you on the way. The first one to verify your VPN is working right and the second to verify your workstation responds properly to RDP requests.

That will significantly narrow down your search to your VPN connection being mis configured or an issue with your firewall and VPN or possibly your workstation having an RDP issue.

The new MS Remote Desktop for the Mac works very well (just remember that a two finger tap is a right click) and I have had no issues connecting with a variety of Win7, XP workstations and 2003, 2008, 2012 servers. so it is unlikely that is a problem.

And one more thing, do you have Little Snitch configured to block MS Remote Desktop?

  • Thank you for your detailed answer. I would have to try the steps detailed before I can accept your answer. Also, I do not have Little Snitch configured. – shunyo Jun 3 '14 at 1:48
  • Just as I was answering Little Snitch popped up for a wholly unrelated thing, figured I best mention it. And Randy, below, has a couple of good points as well – Steve Chambers Jun 3 '14 at 17:48
  • I managed to get it working. The hitch was the Windows firewall. Thank you for your help. – shunyo Jun 5 '14 at 14:39
2

One more thing... test your remote connection from another system at work. It will save you a lot of running around.

Being on the VPN you might have direct network access, but it is also possible for your network admin to filter such traffic to keep hackers at bay. You may have to consult with IT to request an exception for RDP on your IP.

0

I had the issue where I could not RDP over VPN but I could when @ home on same LAN. Modifying the OS X VPN settings to send "all traffic over VPN" fixed my issue.

  • It's helpful if you explain how to change the setting you described; even a screenshot would be excellent here. – Allan Sep 8 '16 at 11:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .