I'm having problems with my Bluetooth on my MacBook Pro Retina early 2013 OS X 10.9.3

It is constantly losing connection for a few seconds with my Magic Mouse and my Bluetooth speaker (Bose Soundlink Mini) occasionally even resetting the connection so I have to reconnect both.

I started having this problem just recently but it's not the speaker's fault (I've tried others) or the mouse's fault—I've tried disconnecting it.

I have also tried restarting the computer, freeing some memory and so on...

How I can I fix this?

  • and there are no solid walls in between, and any other BT devices that you know of trying to connect
    – Ruskes
    Commented Jun 1, 2014 at 17:35
  • 3
    Hy buddy, I am with the same problem. I am 99% sure that it's the bluetooth capacity that does it. In my case, when I use only the bluetooth headphone, it's all fine, but when I connect the keyboard and mouse (bluetooth), than the sound fails/gaps/lag. A detail is that, if I change my bluetooth headphone to headset mode (which reduces the quality of sound) than I can hear the sound with no lags or gaps, but audio quality is the worst. Also, when the headset is connected, I can feel the mouse lag, a little, but can feel it. Please, if you can find some solution, share with us. Thank you.
    – user88482
    Commented Aug 22, 2014 at 15:03
  • also have the same issue when my phone is nearby with bluetooth enabled. super weird. Music starts lagging on the bluetooth headphones (from macbook), until I turn my phone's bluetooth off...
    – Tiago
    Commented Jan 7, 2023 at 12:35

7 Answers 7


I don't know that there's anything you can do about this—speakers just use up a lot of Bluetooth's available bandwidth. While I've never had trouble with JUST a speaker and mouse, I've found that if I connect a Bluetooth mouse, keyboard, and speaker at once, the speaker becomes horribly stuttery until either the mouse or keyboard is disconnected.

You say you've already tried different speakers; I might try different mice as well. You could try a USB Bluetooth adapter, but there's no guarantee that it will be any better. Also, if you have any additional Bluetooth devices you didn't tell us about, definitely disconnect those as well.

(At one point, I set up Eventscripts to automatically disconnect my keyboard whenever a Bluetooth speaker was connected. It worked, but was somewhat fragile, and I don't recommend it.)

You could also try lowering macOS's Bluetooth audio quality in the terminal so it uses less bandwidth. I have never been able to get acceptable results this way, but it could be worth a try. https://lifehacker.com/fix-your-bluetooth-audio-in-yosemite-with-this-terminal-1670380974

You're not going to like this solution, but I would recommend replacing either the mouse or speaker with a non-Bluetooth alternative, such as a wireless mouse with a USB dongle or a wifi speaker that works over airplay.

Sorry this isn't the answer you wanted.

  • Thanks. This helped me. The problem was not the mouse, it was the magic keyboard. so just connecting the magic keyboard with the USB, deactivated the keyboard BT connection (since typing is now done over the usb wire - and also I noticed in the BT menu, the magic keyboard became grayed out.). The audio got immediately better. Not so magical after all...
    – JohnnyJS
    Commented Jan 26, 2021 at 9:11
  • 1
    Adding to the above, the mouse Im using is over bluetooth, but it is not from apple (so maybe magic mouse does cause interference) but it is from another brand - and never had to do anything with the lagging.
    – JohnnyJS
    Commented Jan 26, 2021 at 9:13
  • I'm using a Bluetooth headset and a Bluetooth mouse (Logitech Pebble, not Magic Mouse), and I experience disconnection and jittery sound. I turned off the mouse, and lo and behold, the Bluetooth headset worked flawlessly. As a workaround, I changed Pebble to Wireless mode. It's a shame that they can't be both Bluetooth.
    – Ardee Aram
    Commented Apr 22, 2021 at 13:58

Check the battery level in your keyboard or mouse. I've found this happens consistently when the peripheral battery is running low and the device seems to start spamming the Bluetooth connection with "help I'm running out of juice" requests. Swapping out your batteries for full ones will reliably fix the issue.

  • Thanks for your suggestion but this did not solve my issue.
    – Michael
    Commented Mar 29, 2017 at 23:17
  • 1
    Thanks, this fixed the issue for me on Mojave / iMac 2011 27". I replaced my Magic Trackpad batteries and my Sony BT headphones works correctly now.
    – passatgt
    Commented Feb 16, 2019 at 22:16
  • Another thing I have found with my Bose Wonderboom speaker is it's quite happy to connect to multiple devices so will connect to both my iPhone and Mac when I start it up, which then results in the speaker glitching when playing music. Simply disconnect it from the device(s) you are not using to play music and it then works fine.
    – Dave Sag
    Commented Feb 17, 2019 at 3:33

I had a related problem which was driving me nuts, & it took forever to track down. Seems wifi was stopping my Apple Magic Mouse from working - turns out the macBook was sharing my connection on channel 11, & as soon as I stopped wifi sharing the mouse worked great. I've got it sharing on channel 48 (5GHz) now, & so far everything works perfectly.

As bluetooth & wifi can share the same frequency band, it makes sense to use the 5GHz band for wifi, gives your bluetooth stuff more space.

  • I suffered from strange lag, especially from starting apps that used hand off. My headphones, mouse and keyboard would lag like crazy. Disabling 2.4GHz worked for me. Commented Apr 14, 2021 at 12:19
  • OMG! Wifi sharing!!! This just saved my sanity thanks @SomaMan!
    – cybertoast
    Commented Jan 6, 2022 at 9:53

It happened to my JBL Flip 5, so I performed a full reset of JBL and reconnected it to my MacBook again - voila - no lag and no Bluetooth interference. It seems like it comes back (much less) after reconnect or switch back from another bluetooth device. I performed a full reset again – no lag again.


I have tried several ways but nothing worked, except one: re-connecting the mouse and the speaker.

Here is what did the job for me.

  1. Remove the Bluetooth connections of the devices (go to the Bluetooth symbol on the top right corner -> Bluetooth preference, click on "x" to remove)

  2. Open Terminal, remove the connections

    sudo rm -rf /Library/Preferences/com.apple.Bluetooth.plist
    sudo rm -rf ~/Library/Preferences/com.apple.Bluetooth.plist
  3. Reconnect the devices (via Bluetooth symbol, top right corner)


If your mouse is first generation Magic Mouse, it uses Bluetooth 2.0. Devices using slow Bluetooth versions take more time slots, and it reduces the available time for other devices. Change your mouse to second or third generation Magic Mouse, it will resolve the problem. The second generation uses Bluetooth 3.0, and the third generation uses Bluetooth 5.0.

I have both first and second generation mice, and the problem with Bluetooth headphones appears only with the first generation mouse.

  • 1
    Bluetooth 1.0 is more than sufficient to handle the minuscule amount of data going between the Mac and peripheral device. The issue was poor shielding from electronic noise.
    – Allan
    Commented Feb 27 at 9:38

If I just turn off my magic mouse, and turn it back on, that seems to fix the issue for the time being

  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. You can also add a bounty to draw more attention to this question. - From Review
    – Alper
    Commented Aug 25, 2022 at 4:42
  • @Alper, the question was Any ideas?. This fixes the issue for me.
    – SeanMC
    Commented Aug 25, 2022 at 16:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .