6

I was playing around with the Find My Mac iPhone app (just testing it out) and hit the "lock" option. My MacBook Pro is now locked and I have no place to enter the 4 digit PIN.

When I start it, it shows the Apple logo with a loading circle and it shuts down. If I start whilst holding alt it asks for the PIN, which I enter, then it shows three partitions: Macintosh HD, Recovery & Windows. If I select Windows it works perfectly, but the two others show the problem with the Apple logo and loading circle before it shuts down.

  • 2
    @Buscar Could you expand on how you intend the OP to do this? They have mentioned that Recovery doesn't work and shows the Apple logo… – grg May 31 '14 at 17:07
  • 3
    Are you able to boot into internet recovery? option + command + R at the chime. – njboot May 31 '14 at 17:49
  • 2
    @njboot Good question, lets see what you get. You can see what I got. – Ruskes May 31 '14 at 19:24
  • 1
    the internet recovery fixed it i missed that lol thanks alot bros here is the real genius bar thank you! – axtonDZ May 31 '14 at 22:45
  • 1
    @njboot - I would recommend posting that as an answer, so that this question appears as answered. – Faiz Saleem Jun 9 '14 at 18:21
3

Boot into internet recovery. Hold down option + command + R at the chime.

Use Disk Utility to repair the volume and then reboot your machine normally. You should be able to unlock it now.

  • That doesn't sound very secure. – Ian Warburton Jun 10 '16 at 0:18
  • 1
    does not work in el capitan. – JP Hellemons Jul 5 '16 at 12:49
  • 2
    @JPHellemons i retroactively apologize for not being able to predict how this will work in the future. – njboot Jul 6 '16 at 5:32
  • @njboot no problem. I just wanted to let other people know my experience with el capitan. Maybe it saves them time and effort. – JP Hellemons Jul 6 '16 at 6:49
  • @JPHellemons understood, makes sense. sorry for coming off as as an a*hole. cheers pal. – njboot Jul 6 '16 at 7:04
2

I did face similar issue on Nov 6 2014 with my existing Mac Book Air 2012 model when I got my new iPhone 6+ and was "testing" iCloud mac locate/lock feature. Man, it was frustrating and i was panicked when i could not unlock using the same "4 digit" pin that i had entered while locking the mac from my iPhone. every wrong try was penalized, i had to wait and restart again. Nothing worked and finally i saw this message " Wrong password" and no text box to enter pin [ 4 digit box] at all after 1 hr waiting..each time ..that was killing me. At some point i lost my hope.

What I did to have it worked -

"option+command+R" -> because of this i was able to get back my "4 digit pin unlock text box" ..I could not go past it.

option+command+P+R" -> pin window gone to ashes, straight to user account login screen..

Long Story... 1. Fixed an appointment with apple genius bar - Nov 6 night 2. Showed up at the store nov 7 eve, Had with me my purchase record (lucky, had my email)and photo id for verification. explained him that i could not unlock using my known pin from icloud, he said that "should have worked". 3. The guy told he is going to unlock firmware lock from backend apple servers. 4. came back after some 20mins and told me that the firmware password was unlocked. 5. And he was hoping i could now login, that didn't happen.. same message .."try after 60 mins!" 6. The fact that it is still showing locked from my iPhone, I was not convinced. He told if it did not work after 60 mins, then it could not be fixed anywhere ..huh..genius.. I was not believing him at all at that point! 7. Came back home, tried after the time passed, no result. 8. read some stuff on internet, tried internet recovery "option+command+R" while restarting before chime..after that i could see again "pin unlock" to enter the pin. obviously same issue, back to stage 1. 9. Tried NVRAM reset "option+command+P+R" while restarting again, I could see reset flicker and restart screen..and behold, the user login screen appeared..hurray :)

Long story short, don't know if apple store guy did reset the firmware lock, but my situation was only solved by this two steps at home. since i didn't try them before going to apple store, i can't be sure what expertise the guy brought to this situation.

"option+command+R" -> because of this i was able to get back my "4 digit pin unlock text box"

option+command+P+R" -> pin window gone to ashes, straight to user account login screen..

Now suddenly a happy guy - New Jersey / USA. Class assignment due on Nov 10 and my MBAir is safe now. My Mac is encrypted and have multiple partitions, if that is important.

  • I hope they fixed it by now, because my MacBook was stolen and I would hate to know that it is that easy (once you learn how) to bypass a locked Mac. Perhaps yours was unlocked because of the genius action on the backend? – lpacheco Sep 14 '15 at 20:50
  • Did not work for me, still at the grey lock and pin bar screen. Please help, as the computer is completely unusable right now. I think that the apple guy did do something, as I followed the option+command+P+R steps and still get the PIN screen. – DevilApple227 Aug 23 '16 at 22:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .