2

I have an iPhone 5s. Just like the title said, whenever my iPhone or iPad is connected to Wi-Fi I can't connect to some games like Puzzle and Dragon even though I can browse using Safari, use Facebook, Twitter, Instagram just fine. I keep getting connection error (in the game of course) whenever I open that game (not only that game actually).

I've tried changing the DNS from the default 192.168.1.1 to Google's and resetting the cache (airplane mode -> on -> off). But to no avail.

Have tried to open the game on my father's iPhone and iPad, and my sister's iPhone too. I suspect the problem is that my Wi-Fi configuration isn't compatible with iOS(?).

While my iPhone can't, my friend's Android can play the game just fine using my home's Wi-Fi network.

Please help me fix this.

7
1

Looking at your connection it does not shows full WiFi signal strength?! Why is that?, Try getting closer to the source.

After reading the game requirement, you would be connecting to they game server.

So most probably the problem is not your Internet setting but they server, since your friends Android works on your network.

Try Pinging they server to see if that works.

Reset your DNS settings to standard, thus remove any other settings but your router. The DNS should be issued by your ISP provider.

Go to Starbucks and try it there.

If not, try using a proxy server.

4
  • I tried to login the game with my phone and router not farther than 1meter. My friend's android can even login not in one room with the router. – zoezachary May 29 '14 at 13:43
  • OK, still the signal is not showing the full strength. Delete the current WiFi connection and start over. – Ruskes May 29 '14 at 13:46
  • Also Temporary Disable your Firewall in system preference to test, but enable it afterward. – Ruskes May 29 '14 at 13:56
  • the signal not showing full strength because I doing the screen shot at my own room not at the same room as the router. Hmm firewall, maybe that's the problem I never set up a firewall on my router so it didn't cross my mind. – zoezachary May 29 '14 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .