2

I have a 13-inch MBP with the latest OS X version.

Problem

Yesterday, I went to the Recovery Mode and performed Repair on my boot volume. I was not having a problem, but I just wanted to verify and repair as a regular maintenance. The Disk Utility said some kind of error (I cannot remember, but something about EFI?), and I cannot start my computer since then (question mark folder icon when I try to boot).

I have tried the following

I tried to recover the drive by going into the Recovery Mode, but when I press Option key for boot options, I just have an empty grey screen have no option(not even the recovery volume). I have also tried to enter into the Single User Mode, but it goes straight back to the question mark folder icon. Just in case, I performed PRAM and SMC reset, but still no dice.

Next, I tried to boot with Command+R pressed, and the computer went into Internet Recovery Mode, which works fine. Then, I went to the Disk Utility, and my SSD is on the list with the volume that has OS X(only volume on the entire disk except recovery volume, etc). I use FileVault2, and I can unlock the volume and mount it without any problem. When I do Verify Disk, it says that the volume appears to be OK. Also, performed fsck using Recovery Mode's Terminal, and it still says that "The volume Macintosh HD appears to be OK," the exact same message that I got from GUI disk utility. I also tried to unlock and set the volume as a start-up disk, but I still get the question mark folder icon.

If you need further details, please let me know! Please save me!

  • It should have just worked fine after you did the Internet Recovery.- reinstalled the OS. You are messing around to much. Macs do not need regular maintenance (specially not using the Recovery mode) other the deleting the unwonted apps and files. – Ruskes May 28 '14 at 20:02
  • 1
    Boot again in Recovery Mode (Cmd+R), but this time start the Terminal. In the Terminal type in "diskutil list" and post the result (screenshot f.e.). As Buscar said, you probably killed your EFI Partition and it will not show up. – J.C. Feb 23 '16 at 7:51
1

You managed somehow to kill your EFI. (EFI is the boot loader)

EFI is in a Hidden partition on your hard drive.

Obviously you found it and kill it?

Just to say, in reading your activity, you do mess around to much.

Macs do not need regular maintenance specially not using Recovery mode.

You can get help from here to get a copy of the EFI.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .