3

I'm using Internet Sharing to convert Ethernet into a wifi hotspot through my Macbook Pro. I'm using the latest version of Mavericks, and today suddenly my internet sharing stopped working. I tried looking for people with similar problems using Google but couldn't find any completely similar stories. Things I tried:

  • set up Internet Sharing again using a different setup (e.g. different channel)
  • checked

sudo launchctl list | grep bootp

in the terminal (found that using Google), but it was set on anonymous already

  • unplugged my ethernet cable, although my internet on the Macbook works just fine

Maybe something that helps: whenever I try Internet Sharing the corresponding icon very briefly appears but then goes on into a icon indicating looking for wifi.

ifconfig gives me:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    nd6 options=1<PERFORMNUD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
    ether a8:20:66:4b:c1:8d 
    inet6 fe80::aa20:66ff:fe4b:c18d%en0 prefixlen 64 scopeid 0x4 
    inet 192.168.0.6 netmask 0xffffff00 broadcast 192.168.0.255
    nd6 options=1<PERFORMNUD>
    media: autoselect (100baseTX <half-duplex>)
    status: active
en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 5c:96:9d:91:4c:53 
    nd6 options=1<PERFORMNUD>
    media: autoselect (<unknown type>)
    status: inactive
en3: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether d2:00:12:7b:27:00 
    media: autoselect <full-duplex>
    status: inactive
fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 10:dd:b1:ff:fe:27:b2:70 
    nd6 options=1<PERFORMNUD>
    media: autoselect <full-duplex>
    status: inactive
p2p0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 2304
    ether 0e:96:9d:91:4c:53 
    media: autoselect
    status: inactive
bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether aa:20:66:b4:91:00 
    Configuration:
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en3 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 6 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: <unknown type>
    status: inactive

Please let me know if you need additional information!

  • question: did you change anything on the access point (router)? – Ruskes May 27 '14 at 18:56
  • please use 'ifconfig' in Terminal and report the results here, that will tell you the settings for each network mode. – Ruskes May 27 '14 at 19:00
  • there is also a answer here that might work for you: apple.stackexchange.com/a/113123/46541 – Ruskes May 27 '14 at 19:07
  • Thanks for your time Buscar, here's a reply to your three questions/suggestions: 1. I did not change anything on the access point 2. I added the ifconfig output in the question above. 3. To be honest, I did see that other post but I couldn't understand how I should use that answer there, please care to explain it to me? – Fraukje May 28 '14 at 14:02
1

Try changing the password for the Internet Sharing WPA2 Personal. I had the same problem where the Internet Sharing icon (WiFi with arrow) would flash for a moment in the menu bar, and then go back to the usual WiFi icon (signal bars.) Resetting the settings for the Internet Sharing network fixed it. (I was messing around with some settings files somewhere inside OS X's directory structure...so serves me right.)

  • I currently do not experience this problem anymore, must have been a Mavericks bug. However, hopefully your comment will be helpful for others experiencing this problem! – Fraukje Sep 7 '15 at 8:06
0

For me, this worked:

  1. Stop Internet Sharing
  2. Turn Wi-Fi Off
  3. kill bootp (sudo pkill -9 -f bootp on the Terminal)
  4. Start Internet Sharing
  5. It asks if you want to Turn Wi-Fi On. Say Yes.
  6. Up Arrow icon!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .