2

Here is an interesting one:

  1. I have 264 purchased songs downloaded on my iPhone
  2. If I go "Songs > Shuffle" it goes 1 of 264
  3. If I go "Siri > Play songs shuffled" it goes 1 of 456

So basically, if I use Siri, it keeps shuffling through every song I have purchased rather than just the ones that have been downloaded onto my iPhone.

I have already tried:

  1. Settings > Music > Show All Music Off
  2. Settings > iTunes & App Store > Show all music off + Automatic downloads music off
  3. Settings > Usage > Music delete + iTune sync to put back only the songs I wanted

How do I stop this?

2

I do not know about a better solution than logging out of the Apple Store. It will prevent Siri from accessing your purchased songs library from there.

  • Clever solution! After googling many users had the same issue but no one had a solution. – cappuccino May 29 '14 at 5:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .