3

Unfortunately I accidentaly hit the REPAIR DISK while my Windows 7 bootcamp partition was selected. Since I have Tuxera NTFS, the button wasn't grey out and I thought at the moment I was repairing the OSX partition. Yes, dumb as hell and now I have to pay for being careless.

So the repair disk ran for roughly 2 minutes until I realize it was the Windows 7 partition. So I cancelled it. Tried to boot on Windows seven and all I have is the blinking underscore for a few moments, then instant restart. Everytime.

So here's what Ive done so far to try to fix it:

  • Reset SMS/PRAM
  • Disable Tuxera/Unmount Windows partition
  • Run Windows Repair disk and go through Startup Repair, Chkdsk /f C:, bootrec stuff (rebuild bcd shows 0 installations), system restore to previous point (cant finish due to errors and shows "Unkown" at the top the window).

None worked.

Disk list on OSX shows me this (I have no idea if that is right or not):

enter image description here

How can I fix that partition? I still have access to the Windows files with Tuxera, so maybe I could manually replace the damaged files? Or maybe a terminal command could fix it?

Open to any suggestions (besides clean install obviously).

1

A bit late, but maybe others still look at this.

First Aid may have messed up the partitions information. There are two separate places where the partitions are registered:

  1. In the first sector, the MBR - this one need to identify the Windows partition plus the GUID partition range.
  2. In the GUID table, which usually starts at sector 1, up to 63.

It is possible that First Aid reset the MBR to only list the GUID partition range (i.e. the entire disk). In that case you need to re-add the Windows partition (even if both overlap).

I've written some procedures for this here: http://blog.tempel.org/search/label/BootCamp and here: http://www.tempel.org/WindowsWithoutBootCampAssistant

You could also try to see if Boot Runner (https://twocanoes.com/products/mac/boot-runner/) helps fixing your partition and Windows boot records.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .