Recently I played a TV show on my TV using HDMI and used clamshell mode for my Macbook Pro. Now whenever I'm in Safari, both the menubar at the top and the Dock automatically hide. It only happens when I'm in Safari, though; whenever I'm in Mail, Textmate, or any other app, the menubar and Dock show normally. I can ask the Dock to not auto-hide, and it keep this setting until I switch to another app - if I right click on the Dock and select 'Turn Hiding Off' and switch to another app, it forgets and hides again.

Is there any setting that I can change to make this not happen?

Edit: I think this was a bug, since the suggestions from both @AaronEllington and @David Corbin weren't applicable; I wasn't currently in full screen mode and hitting the escape key didn't do anything. In any case I accidentally closed Safari and it was fine after reopening. I'm keeping this question open in case anyone else experiences the same issue or if it happens to me again.

  • What you describe just sounds like running apps in full-screen. ctrl command F. Furthermore, you might want to change your title, as your question is only about Safari. Commented Oct 8, 2014 at 8:50
  • I'm interested in a cause and solution too; however this happens to me in mail only.
    – user101031
    Commented Nov 17, 2014 at 0:31

2 Answers 2


It sounds like what you are describing is what happens when you go in full screen mode in any app, the menu bar and the dock hide regardless of the dock auto-hide settings. I would suggest just resizing the safari window instead of putting it in full screen mode. (If that is what is happening.)


Simply open Safari and click the Escape key and you should be back to normal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .