When I try to take a screen shot (Command + Control + Shift + 4) I hear the camera shutter sound but no image appears on my desktop.

I Googled the problem and tried to change the saving location using the terminal command line as such:

defaults write com.apple.screencapture location ~/Desktop/

but this did not change anything.

Would anyone know what I can do to fix?

  • 2
    Two things… First, what happens when you try this? Command-Space (or click on spotlight) then type ‘screen shot’. It should show a list of all of the screen shots that you’ve taken. Then you could find out where they’re being saved by default. I’d then click on the ’show all in finder’ to get a window open which would allow you to sort. Second, instead of using ‘~’ in your defaults write, try /users/yourhomefolder/Desktop instead. I don’t think that this command understands the tilde character. – mockman May 25 '14 at 5:06
  • Did you ever get a solution to this? I'm having the same issue, and none of the solutions I found on Google have helped, either. Repaired disk permissions, manually set the screen capture location, killed systemuiserver, rebooted... nothing. Worth noting is that it broke in between screenshots - I saved one, then did another selection in a different part of the same window, and the second one didn't save. – Mark Reed Sep 11 '14 at 20:50
  • @MarkReed no I didnt - its still playing up. I ended up downloading the Lightshot app: app.prntscr.com/en/index.html its a bit more user friendly too – MeltingDog Sep 11 '14 at 23:40
  • Found out what's going on - see my answer below. – Mark Reed Sep 11 '14 at 23:55
  • @caldwell Your edit removed the crucial part of the question where the problem was that OP was facing! – grg Nov 15 '17 at 20:04

16 Answers 16


When I try to take a screen shot (Command + Control + Shift + 4)

That's the problem. The shortcut to put a screenshot on the desktop is just Command + Shift + 4 (or 3). Don't press the control key; when you do, it copies to the clipboard instead. That's why you're not getting a file on the desktop.

| improve this answer | |
  • On my mac Its copy to clipboard without <kbd>Control</kbd> key press. I am using only <kbd>Command</kbd><kbd>Shift</kbd>-<kbd>4</kbd>. what is the way to same it to desktop or other location ? – roottraveller Dec 4 '19 at 6:39
  • If that's true, @roottraveller, then you've changed the default keyboard shortcuts, and you will have to look in System Preferences to see what they have been changed to. – Mark Reed Dec 4 '19 at 15:24
  • thanks that solve it. – roottraveller Dec 4 '19 at 16:27

Same problem here: I couldn't see the screenshots on the Desktop anymore (also, I couldn't see them when I viewed the ~/Desktop directory in the finder. However, I checked the ~/Desktop via the Terminal app, and everything was there (indicating that I used the correct keys).

enter image description here

The simplest solution actually helped: I just relaunched the Finder and everything went back to normal!

enter image description here

| improve this answer | |
  • 1
    I had a similar problem. Icons were not visible in Finder, but were visible in terminal. I had around 200 screenshots on the desktop. – Mike Causer Feb 11 '16 at 0:09
  • 1
    Force Quit on the Finder worked for me too. – JGallardo Jul 7 '17 at 1:51
  • Force quit on Finder didn't work for me - I had to restart my computer. – Alex Mar 18 '19 at 16:42

As Mark had answered, the issue with the screenshots not saving to the desktop is that the OP was using the wrong keyboard shortcut. Command + CTRL + Shift + 4 does not save to the desktop... instead it saves to the clipboard.

A complete reference of screenshot commands is below, for those interested:

Saving to the desktop

Command-Shift-3: Take a screenshot of the screen, and save it as a file on the desktop

Command-Shift-4, then select an area: Take a screenshot of an area and save it as a file on the desktop

Command-Shift-4, then Space, then click a window: Take a screenshot of a window and save it as a file on the desktop

Saving to the clipboard

Command-Control-Shift-3: Take a screenshot of the screen, and save it to the clipboard

Command-Control-Shift-4, then select an area: Take a screenshot of an area and save it to the clipboard

Command-Control-Shift-4, then Space, then click a window: Take a screenshot of a window and save it to the clipboard

| improve this answer | |
  • 1
    + from me for sharing the complete reference – bjbk Sep 4 '15 at 22:30
  • On my mac Its copy to clipboard without <kbd>Control</kbd> key press. I am using only <kbd>Command</kbd><kbd>Shift</kbd>-<kbd>4</kbd>. what is the way to same it to desktop or other location ? – roottraveller Dec 4 '19 at 6:37

None of the previous answers worked for me but, with Mojave, this one did the trick.

Instead of doing Command+Shift+3:

  1. perform Command+Shift+5
  2. In the Options, make sure "Desktop" or "Other Location" is selected
  3. Also make sure that "Remmember Last Selection" is checked
  4. Perform a "Capture"

Then, next time you will do Command+Shift+3, it should be working.

| improve this answer | |
  • I did this, and even the screenshot from CMD + SHIFT + 5 did not save anywhere, doesn't even show as a recent file anywhere – Quinn Jan 6 at 15:27
  • That one worked for me. the Command+Shift+5 overrides the other screen capture shortcuts and it was saving to my clipboard instead. THANKS MYOCH! – user280725 Mar 24 at 15:22
  • This worked for me - Desktop was already selected, but I selected Documents then back to Desktop. Pressed escape to exit withouut making a recording, now Cmd + Shift + 4 was working again. – JanErikGunnar May 25 at 9:12

If you have installed Dropbox it can change where/how screenshots are saved.

| improve this answer | |
  • There they are!! Weird that running defaults write com.apple.screencapture location ~/Desktop/ didn't change this behaviour. – Herman Nov 18 '19 at 10:36

You did all correct but missed the last line after changing the location.

To have the changes take effect, you then must type:

killall SystemUIServer
| improve this answer | |

On my machine this happened (OS 10.9.5) I just had to restart (not reboot) and the desktop-save was restored. Better than that: the images that I thought hadn't been saved appeared as they should have.

| improve this answer | |
  • 1
    Similar here: Suddenly not screenshots were saved anymore (to desktop or clipboard). But rebooting did the trick! (maybe a "restart" would have sufficed; not sure) – Domi Jun 6 '16 at 8:29

Go to the DropBox Preferences and "unmark" 'Share screenshots using Dropbox'

| improve this answer | |
  • I do not see where in the question the OP said that they were using Dropbox. – AMR Oct 28 '15 at 1:55

I actually just got this problem, it was caused by my Desktop being locked for some reason. It may be worth checking whether that is the case.

More broadly, you can view your Mac's screenshot logs by launching the Console. The process you're looking for is screencaptureui. For me, with this error, I got a message:

error   07:34:49.747167 -0400   screencaptureui Failed to write screenshot to /Users/ifly6/Desktop//Screen Shot 2019-09-10 at 07.34.47.png. You don’t have permission to save the file “.Screen Shot 2019-09-10 at 07.34.47.png” in the folder “Desktop”.
| improve this answer | |
  • Do you have any idea how to fix this @ifly6 ? I'm also experiencing this issue. – Andy Oct 16 '19 at 18:56
  • Just restarting my computer actually fixed this issue. – Andy Oct 16 '19 at 21:06

At lease on Mac Yosemite, if you have Dropbox installed, this is a default setting in Dropbox. You can select if you want the older "put the screenshot on the desktop" method, or if you want to integrate your screenshots with Dropbox.

Go to Dropbox > Preferences > Import > Screenshots and check or uncheck the option to "Share screenshots using Dropbox". With this box unchecked, your screenshots will save to the desktop.

| improve this answer | |

I upgraded to el Capitan and found the shift-cmd-4 had stopped working. Tried everything mentioned above and elsewhere. Have got it working again but only by re-programming the shortcut to Ctrl-p (reminds me of my old Microsoft days...) via System Preferences > Keyboard > Shortcuts > Screenshots. Hope this helps!

| improve this answer | |

I have a mac mini and my screen shot stopped working this morning. This is what I did and so far it is working: Go to system preferences click on spot light - at bottom I saw yellow warning symbols click on warning symbol new dialog appears click on (screen shots) and DESELECT ALL but third option (Save picture of selected area as a file) leave as command/shift/4

Snap shot now works and saves file to my desktop.

| improve this answer | |

I was having this problem too, I was using Command-Shift-4, then select an area: It did the sound like it would take a screenshot of an area and save it as a file on the desktop . . . but previously it had been linked to dropbox. So because dropbox wasn't running correctly, it wasn't doing anything. I reopened the dropbox application and that got things sorted.

| improve this answer | |

I couldn't find my screenshots either so I asked Siri on my Mac "find last screenshots" and she took me to the latest ones I had taken. From there, I went to the Finder search and I typed in the name of the last screenshot I took, which in my case was screenshot 2017... (I still had the Siri open to see the name) and I found them on the Finder. Finally, I saved the shortcut to the desktop with a button on the right hand corner and I don't know why but now they show up directly on my desktop again. Hope this helps someone :)

| improve this answer | |

Simply CMD + SHIFT + 5 to pop the config bar. Click Options and Make sure you have selected Save to Desktop or whatever you want to do every time you press CMD + SHIFT + 3

Now, some short explanation: For my scenario, I use Quicktime a lot to record screen. Since macOS Catalina, Quicktime toolbar changed and somehow that same toolbar controls you screen-capture shortcut behavior. However, when you CMD + SHIFT + 5, that bar keeps its own configuration separate from Quicktime's.

| improve this answer | |

Just relaunch Finder and you'll be back to normal. Easy peasy.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .