2

It seems like whenever I use a device that's not made by Apple (USB mouse, bluetooth speakers) invariably the pinch to zoom and rotate features on the Magic Trackpad will stop working after awhile in all apps. I tried to disconnect and re pair trackpad, disable and enable the features in settings, close all apps. The only thing that will make pinch to zoom come back is resetting the computer.

Is there any other way (terminal, etc) to make the trackpad work correctly without resetting the computer? I really dislike ruining my uptime.

This is on a recent iMac with Magic Mouse, Wireless Keyboard and Magic Trackpad on OS X 10.9.3.

1

Go into the trackpad settings in System Preferences and uncheck every single checkbox in all the tabs (pinch to zoom etc. etc.) , wait 5 seconds and recheck all the box you use. (sometimes I switch apps before rechecking the checkboxes and with more than 5 seconds).

You can also try

pmset displaysleepnow; sleep 5; caffeinate -u -t 1

Your screen will turn off for 5 seconds and then turn back on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .