A friend of mine asked me to help with his MacBook as Safari didn't load any site.

I connected to his computer using TeamViewer (so internet is basically working), and then did a ping on Google.com, which worked. His Mac runs on OSX 10.6.x (Snow Leopard) with Safari 5.x.

I've tried a few things including:

  • PRAM reset
  • Delete cookies and browser cache
  • DNS flush
  • Delete cookies/cache/plist in Library
  • Delete and reinstall Safari.app

Non working. I tried downloading Firefox using curl but that seems also not to work.

Any idea what could be wrong?

edit: No proxys active

  • 1
    Check his proxy?
    – Mathias711
    May 21, 2014 at 23:02
  • 1
    What exactly do you mean by not loading - what does Safari and Firefox do?
    – mmmmmm
    May 22, 2014 at 11:00
  • @Mark firefox is currently not installed. safari does not load any page, it tries loading but after a few minutes it says unable to connect (does not matter if www.google.com or <ip of google.com>)
    – Zaiborg
    May 22, 2014 at 13:37
  • @Mathias711 ill check that when i am at home
    – Zaiborg
    May 22, 2014 at 13:38
  • @Zaiborg so the bit re Firefox is just saying curl does not work?
    – mmmmmm
    May 22, 2014 at 13:52

7 Answers 7


I solved by making sure the network settings not picking any proxy options under Network > Advanced > Proxies.


Is there any app such as Little Snitch that is installed? If so, it could be blocking browsers but not Team Viewer and not Mail.

  1. Open a Finder window. From the Finder menu bar click Go > Go to Folder
  2. Type or copy paste the following: ~/Library/Caches/com.apple.Safari/Cache.db.
  3. Click Go then move the Cache.db file to the Trash.
  4. Quit and relaunch Safari to test.

I tried various options including the proxies The only thing that solved it was System Preferences > Network > Assist me > Connect to the internet And it solved it on its own


What about putting Firefox or Chrome on a USB stick and just copying it via Finder? If they also do not work, I would suspect something more generally wrong, not Safari itself. Might have to use portable version of those apps.

UPDATE: What about any recently installed firewall software? Anything that might have installed a webfilter or a webfilter appliance that might sit between your Mac and the gateway? Is NAC enabled on the network, preventing you from getting out until you hit a specific site for authorization?

  • installing firefox resulted in the same behaviour ...
    – Zaiborg
    May 22, 2014 at 21:49

Check the DNS server in network preferences for the network adapter you are trying to connect. Usually DNS server ip should be the same as the router ip address.


I encountered this issue (internet on Safari and App Store app not working), and rebooting my computer ended up resolving the problem for me.

Not the answer you're looking for? Browse other questions tagged .