1

we have two Macs, an older iMac and a MBPr both with Mavericks (10.9.3). Only one of them has a very annoying problem with our new synology ds214+.

With the iMac I can access the NAS over the the finder symbol (both AFP and SMB). Also time machine finds the time machine folder on the NAS which was configured over the synology dsm software.

The MBPr on the other hand can access the NAS over different ways: AFP from the browser "afp://ip.adress", smb over the finder symbol. But there is no way I can get it to work with time machine or AFP over the finder symbol. I just get a message saying something like "While connecting to 'DiskStation' an error occured. Maybe the server is not available anymore".

I have a hands off! firewall installed, but it doesn't matter if it is turned on or off.

Due to the fact that it worked for one night with the first backup i am kinda driving crazy, cos ever since I can't get it to work again. I even tried to reinstall OS X from a backup with no success either.

I am wondering if there might be any connection to the fact, that my MBPr doesn't connect to the apple software update server either.

I am thankful for any advice.

1

I wonder if it has to do with the fact that the other Mac is already reserving the disk for use with Time Machine.

I have a very similar setup and could try this myself on monday when I'm back at that computer.

Until then, I suggest you try adding another small partition to the DS, e.g. by using any free space left on the internal disk, or by pluggin a USB drive into it. Then make this volume available via AFP as well, and see if both your Macs can access it normally. That would prove that it has to do with the particular shared partition and not with the network setup.

1

I'm having a similar issue with DSM 5.1.5021 update 2.

Try connecting over finder with ctrl+K and then entering the fully qualified path, e.g : afp://192.168.x.x/ - that should work.

Try adding the user to the "system default admin group" and then see if - when trying to connect through finder - the shares for that user show up.

I have another box running dsm 4.3 which does not seem to suffer from this issue ( also non-admin users can view the shared-folders available to them ).

My "solution" is to add admin-rights for every user ( not that I like it, but I don't have a better solution and the box is only used privately / non-commercial ).

1

add the nas hostname and IP to the MAC "hosts" file, that's how fixed it today.

to edit the host file on a MAC, best way is through terminal, google it.

Good luck

-2

This is a good explanation of editing a Mac hosts file https://www.tekrevue.com/tip/edit-hosts-file-mac-os-x/

  • Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. – fsb Apr 25 '17 at 21:12
  • 1
    Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Tetsujin Apr 25 '17 at 21:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .