3

Came across a bizarre bug (?) in my Mavericks installation. I ran out of HD space, which I should not have been anywhere near.

I ran Disk Inventory X to see where the space was being used, and found that somehow my User directory had been replicated in each apps sandbox.

Any idea what I could have done to cause this?

enter image description here

  • 1
    You are being led astray by Disk Inventory X. Looks like it is following aliases and counting the same physical storage many times. I use Grand Perspective and/or WhatSize which don't do that. – Gilby May 21 '14 at 0:40
  • Disk Inventory X may be wrong or something may have caused those symlinks to be de-referenced and turned in to copies of the data they pointed to. Check with Finder that those directories aren't aliases/symlinks. They are for me: imgur.com/ovL70MI – Ian C. May 21 '14 at 1:17
  • @Gilby I suspected that at first, and verified they were indeed copies. I deleted the files in my User directory, and they still appeared in each sandbox. The other piece is that the numbers all added up, and without those dupes my filesystem should be nowhere near full. This is on an "enterprise" OS X install, so I'm wondering if there is a bug somewhere in that facet. – eskerber May 21 '14 at 2:20
  • I have run Disk Inventory X on my ~/Library. It does not count aliased directories more than once (as I suggested it might be doing). That confirms to me that you really do have a problem with the folders in your Containers. I can't see an easy solution - I hope someone else can. – Gilby May 21 '14 at 6:19
4

The containers folder uses a Unix device called symbolic links. These links are redirects to information stored in a different folder or separate hard drive in your system. This allows for multiple paths to the same files and folders.

Some software applications can not distinguish a symlink from a valid directory and will report multiple copies of the same files and folders. There is really only one copy of the data but symlinks allow for different permissions to be applied to the application or users.

If you do a ls -la command from the terminal the first character of the permission will be the letter l (ex. lrwxr-xr-x) directories start with the letter d and files start with a dash '-' and the file name of a link will look something like this;

 lrwxr-xr-x  1 root  wheel  hidden   11B Jan 10  2014 etc -> private/etc

The first part is the file/folder name that the system is looking for and the part after the -> is the fully qualified path to the actual location of the data data. (See the man page for ls and ln for more detail.)

The function is transparent to the user from the finder but functional to the OS.

For more information do a web search on symlink or symbolic link.

P.S. While an alias that you create provides the same functionality it does it in a different way and the aliases don't backup correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .