7

I recently tried to upgrade a 2008 Mac Pro from Snow Leopard (10.6.8) to Mavericks (10.9.2) using the free upgrade available in the App Store. The upgrade seemed to go without a hitch until the machine restarted, after which I get the Apple logo with a progress bar---it takes about 20 minutes for the progress bar to advance all the way and then the machine spontaneously powers off. When powered back on the process repeats itself.

So far I have tried:

  1. Reboot into recovery using command+r. This works and I'm able to launch the Disk Utility. This shows S.M.A.R.T Status : Verified. Running Verify Disk on the HDD (topmost level of the tree) shows no errors. However, running verify on the Macintosh HD partition does show errors and asks me to run Repair Disk, which tells me I have irreparable errors and suggests that I back up my data and reformat.

  2. Reformat. Still in recovery mode Disk Utility, I first tried running Erase under the Erase tab on

    1. the HDD, resulting in: Disk Erase failed with the error: Couldn't unmount disk. (in retrospect this makes sense because initially I was booting to the recovery partition on the same disk)
    2. the Macintosh HD partition, resulting in: Couldn't open disk.

    Next I tried selecting the HDD and the Partition tab. I attempt to remove the Macintosh HD partition by clicking on the minus, but the system hangs on Preparing to remove partition.

  3. Try USB recovery disk. After all of this failed I started to suspect that Disk Utility was refusing to make changes to the HDD since I was booting to the recovery partition on the same disk. I then made a bootable USB recovery disk using the Recovery Disk Assistant and am able to boot to it by holding the option key on startup. However I am still unable to erase the disk using the methods above and get the same error messages.

  4. Try to force unmount HDD. It appears to me that the system is still mounting the HDD even when booting from the USB recovery, thus preventing reformatting. But attempting to force an unmount fails:

    diskutil unmountDisk force disk1
    

    results in

    Forced unmount of disk1 failed: at least one volume could not be unmounted
    

I'm at a loss for what to try next. It seems unlikely to me that the disk is failing since the SMART status is OK, but I suppose that is a possibility too.

EDIT

Following @chillin's suggestion I tried booting to a Mavericks USB install disk, created following the instructions here. Holding option on startup I'm able to select the USB and boot appears normal, but with the same result that I am unable to unmount the internal disk to format, even using diskutil unmountDisk force disk1 (I get the same error messages for all methods described above). I do notice that the option to reinstall OS X has been replaced by an option to install, so I am confident that I'm actually booting to USB.

EDIT 2

Following @Édouard's comment I tried booting in verbose mode using command+v at startup. It seems that fsck_hfs is caught in a loop "repairing" and rechecking the drive, which it does 3-4 times before the machine gives up and powers down (see picture 1). The line /dev/rdisk1s2 (NO WRITE) catches my attention. Could this be why fsck is unable to make the necessary changes to repair the drive?

Result of booting in verbose mode

  • The next step would be to make a backup or two of the failing/failed HD using Carbon Copy Cloner or SuperDuper to an external disk. These two apps can create a bootable disk you can then transfer back to a brand new internal HD of vastly larger size. Don't trust the failing/failed HD. At. All. The least expensive is to get a new USB external drive for the backup, then open the case and swap drives when you're done. Worked for one of my clients. – IconDaemon May 16 '14 at 21:03
  • "Disk Erase failed with the error: Couldn't unmount disk." When you can't unmount the volume to erase the drive, it's a sure sign the drive is toast. I know this from personal experience. – njboot May 17 '14 at 0:38
  • 1
    Yes, it does smell dead disk. You could still try booting in Verbose mode (hold command and V during startup) to show details of where the boot fails, but I’m afraid disk replacement will have to happen. Do you have your data backed up? – Édouard May 17 '14 at 0:40
  • @Édouard thanks for the suggestion, I tried booting in verbose mode (updated question). – mcwitt May 17 '14 at 20:47
  • keep repeating the fsck till it comes back without errors. Get a six-pack and chips :) it might take a while. – Ruskes May 17 '14 at 22:05
0

I’m afraid your hard drive is dying. Updating can be somehow hard drive intensive, so it’s not that surprising that it died during an update. If you have no backup, copy your important data to another hard drive with another computer1.

You can still try to save it with utilities such as DiskWarrior.

Otherwise, you’ll have to buy a new hard drive and install it in your Mac Pro, then copy your data back to it.


  1. And start doing regular back up right now.
  • I ended up doing a fresh install on a new disk. I'm now quite sure you were right about the old disk--I get the same failures when trying to check/repair the old disk from the new installation (on the new disk). – mcwitt May 27 '14 at 23:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .