I tried to clean install my mid-2012 MacBook Pro Retina and then recover from my Time Machine backup. At first the backup looked like a success and the OS did boot properly. However, I found that there are some files that are gone from the filesystem... Whoa! I was able to find it when I tried to play a music in iTunes, and got the error something like "the file doesn't exist. You have to locate it...".

And so I did search for someone who met the same issue as me, and found that this happens often after the recovery from the Time Machine backup. However, almost all answers there just helps the OP by teaching how to move the directory from the backup to the OS filesystem manually, or didn't get the answer in the first place (not in this site). But I want to know WHY it occurs, and on WHAT directory it occurs.

I've been searching for every directory and its files there that are gone after the backup, and found that my Python directory (~/py/user) erases every file and directory except one file and two directories. I'm pretty, pretty frustrated to see it doesn't recover correctly, and I would have to spend another 30 hours or so just to make sure that all my files in my filesystem do exist, and if it's missing I have to recover it from the backup one by one manually.

I tried to recover it from the Apple AirMac Time Capsule, on which I backed up in every two hours to date. I recovered from the latest backup. I even don't know whether the AirMac's storage can correctly back up my files and it's just the transportation issue that caused the issue here, or the AirMac failed to make a backup in the first place (forgive me, but I cannot check it out - it's pretty unresponsive when I tried to browse through the filesystem. But given that I've found so far, it's likely the former). Fortunately, I also have another backup with thunderbolt, and am now recovering the missing files from it. Usually I use the thunderbolt storage when I recover, but it's a manual backup and I haven't made a backup in 11 days. So I had to recover it from the AirMac... (The thunderbolt storage makes the recover properly the last time I use it, if I'm not missing something in my whole filesystem).

Sorry for the long question, but to summarize, my question are as follows:

  1. Why does such a phenomenon happen?

  2. Is it feasible to prevent this pathetically frustrating effect?

  3. Is there any tendency in directory that is prone to the deletion? As far as I've searched, the Music folder is what most people report, but I don't know whether it's because most people stores a lot of data on it, or it's just the Musics folder's issue. For your information, my Musics folder is missing about 15% of all files.

  4. Is this the responsibility of OS X's backup system, or the third-party storage (including AirMac Time Capsule)? Which is more likely?

My AirMac Time Capsule is one that is released last June, with 3TB storage. The OS is Mavericks 10.9.3, while the OS when I backed up is 10.9.2. Any feedbacks would be appreciated.


I finally confirmed that those missing files from the Time Capsule was NOT backed up in the first place. Whoa! I don't know any reasons that why those files failed to be backed up. Those files and directories don't have a different permission from the other files in my filesystem that was backed up properly. Is there any reasons that some files can be backed up while the others cannot? I've completely lost my trust in Time Machine and the whole backup system OS X provides...

  • 1
    I have the issue of missing files in my backup mostly in ~/Library/Preferences but also a few other files. And this is right after having done a backup. I found some rare discussion online: forums.macnn.com/90/mac-os-x/509489/… discussions.apple.com/thread/5555478 No solution so far, very frustrating. – user95353 Oct 12 '14 at 2:31
  • Yes, I did find those forum here or there at that time, but nobody got the issue resolved. It's insufferably disgusting. – Blaszard Oct 12 '14 at 4:01
  • What directories shown in System Preferences -> Time Machine -> Options – mmmmmm Oct 12 '14 at 13:03

You must log in to answer this question.

Browse other questions tagged .