11

Preface: I have opened a new issue in the Chrome bug tracker because no-one could help so far.

On my OS X Mavericks, Chrome shows an annoying issue: When I open a longer web-page, like the list of questions here on SE, the first scrolling action after a couple of seconds is delayed by about 1/10 second.

This is not restricted to scrolling by mouse. When I hit the arrow keys for scrolling, the delay appears too. I have read almost all posts about scrolling lags on OS X, but all issues I have found seem to be different. My machine is really fast and I cannot complaint about other performance issues. I'm using Chrome 34.0.1847.137 and my system is

enter image description here

Usually, the issue shows as follows. I read a bit on the page, scroll down and the reaction on the screen is delayed. When I don't wait a few seconds between two scrolling actions, everything is fine. This is really annoying because after a while you really pay attention to this issue and it drives one crazy.

I have tried to turn on the frame-rate monitor in Chrome, but this looks fine. Funny enough, it shows the same delay. During scrolling this monitor constantly tracks frame-rate. During the delays, the frame-rate monitor freezes too.

I have tried to turn off extensions and tweak the chrome://flags/ settings without success. It seems like Chrome is going into some kind of hibernate after some seconds.

I should mention, that no other applications show this behaviour. I have tried Safari which seems fine and in other applications I haven't noticed anything unusual.

Does anyone has a solution for this?

Additional information: I need to wait about 5 seconds without doing anything before the issue appears. So when I navigate, scroll, etc and then wait 5 sec, the scrolling delays. Every scroll-direction is infected: up, down, left and right.

  • To find out if there is a memory issue, do you have same problem in another browser? – Ruskes May 15 '14 at 19:04
  • @Buscar웃 Sorry, I wanted to add this information: No, Safari works fine and all other applications too. – halirutan May 15 '14 at 19:06
  • this is a test: when you open a new page in chrome, hit the cmd + down arrow, to jump to the end, now scroll upwards. – Ruskes May 15 '14 at 19:25
  • @Buscar웃 I will try it when I'm back at my office mac and yes, clearing cache and looking at the dev-tools whether some site/thing interferes was one of the first things I have tried. – halirutan May 15 '14 at 20:28
  • @Buscar웃 I investigated a bit more. I need to wait about 5 seconds without doing anything before the issue appears. So when I navigate, scroll, etc and then wait 5 sec, the scrolling delays. Every scroll-direction is infected: up, down, left and right. Jumping to the end of the page and scroll upwards makes no difference. – halirutan May 19 '14 at 10:56
2

I too have this issue. If you stop scrolling for 5 seconds because your reading, then go to start scrolling again, there is a freeze or delay of about 1 second. its noticeable, and very annoying. There are no viruses, and its not a plugin. (I don't use chrome extensions or plugins.) Safari doesn't have the issue, and its machine specific. The identical Chrome on an older iMac, identical OS, doesn't have the issue.

My guess is that chrome has "frozen" the page, to save on CPU cycles, and has to release that and start live rendering it again when it sees you start scrolling. Or maybe its a delay of swapping between graphics mode on the hardware...?

Some interesting extra notes...if a text editor panel is open, such as the one you comment on here, the issue does not exist. If an active video such as on youtube is playing in the window, then there is no lag scrolling either.

If you are scrolling up, there is never a delay, its only scrolling down that has the delay.

You see the mouse pointer change for the items that would be scrolling under it before you see the page even move. So this indicates its some lower level thing that is going on, and most likely graphics related.

  • 1
    Nice findings. Would you consider to add them to the official bug in the chrome bug-tracker? Btw, upvoting the question will make this post become more popular and easier to find. It's almost a year since I posted this Q and the issue still persists. – halirutan Apr 7 '15 at 12:46
2

I had exactly same issue and have just solved it. It was really simple, but I spent 20 minutes on it. Probably it is not the case for other people who posted here, but this is the only page I found googling, so may be this will help somebody else with same problem to save some time.

I had a keyboard option "Turn keyboard backlight off after 5 seconds", and, apparently, it affected performance. I removed it and now everything is just fine.

Sorry for mistakes if any, English is not my native language.

  • 1
    Wow, considering that my question is almost 4 years old, it is stunning that people still have this issue. For me, the issue went away after a chrome update in the past. I can't remember doing anything special. I guess, I just had accepted my bad luck in the past and then at some point it went away. – halirutan Jan 18 '18 at 16:35
1

I have the EXACT same issue, also on a Mac Pro (6 Core). I restored all my files to this new Mac Pro via a Time Machine backup, and the source machine (a late-2013 15" Retina MacBook Pro) doesn't have this issue at all. I've done all the same things you have; resetting things, uninstalling some apps, removing Chrome and trying a fresh install, etc.

On any page that has scrolling, all I have to do is let the mouse sit for 5+ seconds and the next time I try and scroll there is a half-second to full-second pause. It does not occur in any other browser... just Chrome, and just on the Mac Pro.

I'm completely lost on how to fix it... I even added a fresh user account on the Mac Pro to ensure it wasn't a bad plist file; didn't help in the least.

EDIT - Added to Chrome bug tracker as requested!

1

Identical problem. Chrome Version 42.0.2311.135 (64-bit)

Also a MacPro. Could it be happening only in MacPro? Have to switch to Safari for now. I have no problem with Chrome (identical settings) on MacBook.

enter image description here

  • Problem seems to be fixed in Version 43.0.2357.81 (64-bit) – B So Jun 4 '15 at 4:53
1

Problem seems to be fixed in Version 43.0.2357.81 (64-bit)

Happy.

0

I also have the Chrome Version 34.0.1847.137

I have a MBA with ONLY 4Gig RAM 😒

The scrolling in Chrome works very well (using the build in Trackpad)

Here are some settings in Chrome to compare:

Chrome

See the Disable Individual Plug ins !

Click on it and it will open whole new page...

chrome plug ins

Disable anything you do not use and then some more.

  • I set "Click to play" for the plugins and I already turned off (I had not explicitly turned on any dev-plugin) some dev-plugins without result. – halirutan May 19 '14 at 10:53
  • sorry missed your comment above...I would say it is time to reinstall Chrome. The 5 second delay bothers me as if it is some kind of Virus ? – Ruskes May 19 '14 at 11:02
  • I cleared all data from within Chrome, I deleted the application itself and remove all contents from ~/Library which had something like "Chrome" in it. A fresh install of Chrome, without any extensions and all plugins disabled shows the same symptom :-( – halirutan May 19 '14 at 13:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .