7

I use some keyboard shortcuts on my iPhone. This helps a lot, e.g. when typing gn which is replaced by Good night!. These shortcuts are synchronised to my Mac via iCloud. On my Mac I use TextExpander as a sophisticated keyboard shortcut tool and don’t need these iOS shortcuts, as I have hundreds of Mac abbreviations and don’t need shortcuts that work on a phone but not elsewhere.

The answer to my question is pretty obvious: All I have to do is to unable System Preferences → iCloud → Documents & Data. However, a lot of apps rely on this setting being enabled.

What else can I do to prevent the synchronization/use of these abbreviations on my Mac?

4

You have answered your own question, the syncing is included with lots of other things and granular settings are not available. The only way around it is to use just text expander on both iOS and OSX, or just the default text substitution tools, but not a mix. Sorry!

0

Yes there is a quick solution.

On any Apple app: Go to Edit>Substitutions and UNCHECK "Text Replacement".

Hope this helps!

enter image description here

-1

I agree with you. I'm not a fan of turning off a primary feature of an unrelated service to solve an issue like this. It's not really a solution.

According to TextExpander's support there's no mention of official iCloud syncing. You may want to check to see if you have the Local Network syncing option on by mistake.

TextExpander's page on syncing

If that doesn't do it, here's the reality and this will probably come as a surprise to you... iCloud syncs all kinds of settings & data between devices (iOS & Mac) without you knowing it or explicitly allowing it. I've done a great deal of digging lately into how & what iCloud syncs and it's pretty upsetting. I'm seeing documents & preferences being pushed to iCloud for apps that don't have any official iCloud support. I've yet to figure out why some of these apps are immune to the situation, but I'm guessing that apps developed using newer versions of Apple's development software (XCode) are putting their settings/documents in places that get picked up by iCloud without the developer even realizing it.

In my experience, Mac apps that have an iOS counterpart are sharing information without being listed under Documents & Data in System Preferences. Basically Apple seems to be automating some syncing for newly developed apps on all their platforms and they've either failed to prevent inadvertent sharing that the developer didn't intend or they're intentionally doing this in silent thinking they're doing someone a favor. Either way, it's pretty sloppy on Apple's part.

I'd suggest contacting the developer of TextExpander so they're aware of the issue. In the meantime, if it is silent syncing, there's nothing you can manually do to stop it other than your above solution.

This next part I only offer as evidence of what I'm talking about, not to suggest you delete anything from the location I mention. Doing so could create problems and in my tests things just came back during the next sync.

None of the next steps will harm or change anything on your computer. It just opens a folder that's typically hidden. You can close the Finder window when done and no harm will be done.

On your Mac make the Finder active. Select Finder from the Dock or any window or just an empty area of your Desktop and press:

COMMAND+SHIFT+G

Then copy and paste this into the text box and press GO

~/Library/Mobile Documents

You'll see a list of a bunch of data being shared between your devices you probably didn't know about. Sadly this isn't the only place on the system where this tuff is tracked & synced, which is why deleting stuff here won't always do anything. But at least you can see if a folder exists regarding TextExpander.

Oh, remember when you turned on syncing of stuff related to "Finder"? Yeah, neither do I.

Good luck!

  • You misunderstood me. It is not a TextExpander issue but an iOS shortcut issue. – lejonet May 15 '14 at 10:28
  • I see. I assumed you were also using or had used TextExpander on your iOS device as well. Even so, a large part of my answer still applies. Sadly this does mean that there's no other solution other than turning off Documents & Data syncing for all of iCloud on your Mac or your iOS device or both. As I mentioned, the reason this is happening is because iCloud syncs things it shouldn't and you're not able to control that without turning off a section of the service. In your case since it's syncing shortcuts on the OS level, there's nothing else you can do other than what you already did. – sgelliott May 18 '14 at 1:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .