2

Not sure what's going on here. I just imported some photos from my iphone that I took about an hour ago. I have it set to automatically import via iCloud so they were of course already on my Mac anyway.

I'm now trying to edit them, and the first had no issues. But the second gives the message listed in the title of this post, in the edit sidebar:

Image Cannot Be Edited.
This photo or container may be read only

The rest also are all fine. It seems this is the only image that won't allow me to edit it, but I haven't a clue as to why. Anyone have any ideas?

  • I thought this issue had mysteriously fixed itself, but turns out I was looking at a different but very similar photo. The original issue still persists. – Jonathan van Clute May 12 '14 at 16:07
  • Can you check the permissions of the picture causing problems in Finder? – nohillside May 13 '14 at 7:48
  • To my surprise, iPhoto actually can't reveal the file in finder at all. Both reveal options are greyed out. – Jonathan van Clute May 13 '14 at 15:10
  • This sounds more like a corrupted iPhone index then -> support.apple.com/kb/HT2638?viewlocale=en_US&locale=en_US – nohillside May 13 '14 at 15:20
1

I just imported some photos from my iphone ... they were ... already on my Mac anyway.

I like you already.


No one answered for 15 hours, so I'll take a shot... and bump your question to the top of the queue, and maybe you'll get some answers. I'm willing to take the risk of losing some points to do that for you. That's the kind of guy I am :)

The thing about data is that sometimes it gets corrupt. I don't think that's what's happening here, I'm just saying that sometimes data gets corrupt, whether its cosmic rays or eddies in the space-time continuum. There's nothing you can do about it other than have backups. And in this case, iCloud backed up the photo you can't edit in at least 2 places, if not more. So why bother with this photo you can't edit and save, when you just said that you had another copy of it?

That being said, usually the reason you get a message like that means that the file is open somewhere else.

Try quitting and relaunching the application. ;-)

If that doesn't work, try rebooting.

If possible, import the duplicate photo that was already synced from iCloud on your Mac into iPhoto, and see if you can now edit and save the photo.

If that doesn't work, try identifying the location of the photo file in question. Once you have the path to its containing folder, open Terminal, type cd and a space, and drop the folder in the terminal, and hit return. Then type:

   ls -a

and look for an invisible lock file with a file name that begins with a period. If you discover one, delete it with this command:

  rm <.name.of.lockfile>

then check and see if you can open, edit and save the photo in question.


also iphoto won't allow me to reveal the file, the reveal options are greyed out

Does iPhoto tell you the file name of the photo when you hover over it, select it, or select it and click the info button in the toolbar? Perhaps using the filename you can search for it directly with Spotlight in the Finder.


More ideas

Do you see an exclamation (!) mark?

iPhoto Library Manager

  • Thanks for taking a shot, I appreciate it! =) So I like the idea of getting the photo back from icloud, but how would I go about doing that? I don't use iphoto much so not real versed in its intricacies. If I delete the photo in iphoto, won't it be deleted from the cloud too? Not sure how I can import the photo again either since it now only exists in iphoto as far as I can tell. Oh also iphoto won't allow me to reveal the file, the reveal options are greyed out. – Jonathan van Clute May 13 '14 at 15:16
  • Holy crap... I just relaunched iPhoto and now the photo in question can be edited perfectly fine. I was in the middle of a bunch of things so hadn't wanted to reboot, but hadn't considered a simple relaunch. facepalm Anyway, all good now but your attempt to help is very much appreciated! – Jonathan van Clute May 13 '14 at 15:54
  • @JonathanvanClute Congratulations! (Please don't forget to mark your question as solved) – chillin May 13 '14 at 16:27
  • Actually about that... I'm not sure the protocol for this sort of situation. You were very helpful, but technically your suggestions weren't the solution, and if I accept your answer wouldn't that give the wrong impression to someone finding this question at a later date? Personally I'm happy to accept your answer just to say thanks, but it wouldn't technically be accurate. Not sure how to handle this... – Jonathan van Clute May 13 '14 at 22:58
  • @JonathanvanClute : As I have discovered, it is apparently a gray area (must look at all time stamps on the page to see what I mean). But... you know... there is no 'i' in 'team' (though there is an 'm' and an 'e' ;-) – chillin May 13 '14 at 23:34
0

I had a similar problem that "seemed" to affect some of the photos I'd taking using HDR on my iPhone 5. What I did was export to the desktop and opened them OK in another application (Photoshop in my case) and then trashed the original in iPhoto and reimported the edited file. It was now editable in iPhoto. I appreciate that this doesn't solve the basic problem and is no good if you don't have another photo-editing app, but it may be of use to somebody.

0

i had that problem when using pics from the "photo stream" album. One I used the same pic from "camera roll", I was able to edit.

0

We came across this same issue. This solution fixed it http://www.howtogeek.com/219092/why-cant-i-delete-photos-off-my-iphone-anymore/

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Welcome to AD. We are looking for standalone answers. It's ok to include a link but please summarize the necessary steps in your answer. – n1000 Oct 2 '16 at 15:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .