My MacMini, which I bought new around Thanksgiving 2010 from Amazon, has been having quite a few kernel panics. They aren't consistent in any way, but they have become more frequent and now many apps seem to be crashing more as well and I have also noticed Spotlight and Alfred have become painfully slow.

I was about to reinstall Snow Leopard and start from scratch after making a SuperDuper clone on an external for backup when I read on the Apple CD that you can run an "Apple Hardware Test" by holding "D" during startup.

I figured it was worth checking out. Especially since my memory is non-original. I had put 2x 4GB Corsair sticks in it right away that I also got from Amazon a few months before then which I had used in my previous early-2009 MacMini. The memory seemed to have worked fine in both computers. All 8 GB were being recognized. These kernel panics only started happening a few months ago.

Now the Apple Hardware tests, which I tried in every conceivable configuration; swapping slots, removing one then the other etc., did in fact show errors. I wrote down two of the error codes. I believe there were only two unique codes; I suppose the different stick arrangements I used is cause for the variances, but it's possible there were more, but I know for a fact they all started out with the same characters, 4MEM/9/40000000: .

4MEM/9/40000000: 0xa90c1418 & 4MEM/9/40000000: 0xa95de698

However, the strange thing is the Apple Hardware Test only showed this error when I had BOTH sticks installed; either stick in either slot on it's own showed no error. As I mentioned earlier, I tested all possible configurations because I had read that sometimes it could be a faulty slot.

So, with that information, does anyone have an idea how to fix my Mac. Do I need to replace one or both sticks? Is it something else? Is there an app I can use to help diagnose the issue?

As I'm writing, I realized I can still try using both the original sticks that came with the Mac at the same time, but I need to find them. I may wait until tomorrow to try that.

3 Answers 3


It sounds like some sort of RAM issue for sure, and there are a few memtest based programs out there to try and run and see if you run into problems. Rember is a gui based memtest, and applejack is a fairly well known utility script that also contains it.

I dont know why you only got the error with a specific configuration of ram, but with 8GB of addressable space it can take a while to find the bad guy.


I agree with hobs. I recently had a similar problem - random KPs that didn't point to any single process. I tracked it down using Prime95. It has a stress test which according to their README indicates that any errors are almost certainly tied to a hardware problem. Swapping RAM and running the test I was able to confirm that my 3rd party RAM was bad. I should note, Apple's hardware test never found a problem, nor did I find one with memtest (but I probably gave up too soon).

  • Man I forgot prime95, +1 Commented Apr 28, 2011 at 16:11

I found my old stock RAM that came with my Mac and swapped it out and the kernel panics and app crashing stopped. I used it for a few days just to be sure. Then I went back and stuck in only one of the third party 4GB sticks and within an hour I had a few app crashes and a kernel panic. Then I swapped it with the other third party 4GB stick and after a week of use, it seems to be in working condition fortunately.

So ultimately, the answer is the app crashing and kernel panics were definitely due to faulty RAM.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .