0

I'm trying to get an Epson Perfection 1260 scanner working with Mavericks.

When I connect the scanner to my Mac it shows up fine in Printers & Scanners in System Preferences. It also shows up in Image Capture, and quite often it will allow me to do an overview scan. However, at some point the (usually green) light on the front of the scanner turns red, and the scanner disappears completely from my Mac.

How should I start troubleshooting this?

  • Do you know what the red light means per Epson? Does the same thing happen with other computers/OSes? Have you tried a different connection method from the scanner to the computer, e.g. different cable, Ethernet vs WiFi, etc.? – thankyour May 8 '14 at 18:38
1

The red light may mean that the scanner has detected an internal error, so start at that end. First, try the scanner on another system if possible. If it works on another system, then the issue could be the USB connection or the software.

It is not unheard of (though rare) to have a bad USB cable, so if you have a spare, swap it for the current one and see if that helps.

There were sporadic disconnects in the early versions of Mavericks, so a system update may have solved your problem. If not, start troubleshooting by making sure your software is up to date, then remove all other peripherals from your system and connect the scanner directly to your Mac ( no hubs ). Try each USB port in turn, as there are differences in their internal connections.

I doubt that it would make any difference, but you can download and try a copy of vuescan, (hamrick.com) which uses a different driver.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .