0

Since yesterday I've been having major issues with my 15" Retina MacBook Pro (mid 2012 model). When I boot it, the screen is black (no backlight: Apple logo doesn't light up). I do hear the startup chime, and it actually does proceed to boot, but the screen stays dark. After a while, I can hear ticks as I adjust the volume, I can adjust the keyboard backlighting, etc. After it boots, the fans stay on at full speed.

I did a PRAM and SMC reset, both to no effect. After lots of fiddling with plugging and unplugging an HDMI cable to an external monitor, I eventually got the screen to turn on. Most things seem functional, besides it being a bit sluggish and the fans still stay at full speed (and there seems to be a LOT of battery drain). I'm using gfxCardStatus and I notice it isn't really able to switch to the discrete GPU anymore.

Does anyone recognize this issue? I suspect it's a hardware issue (broken GPU? broken connection to GPU?), are there any more tests I can do?

I notice in the system report at Graphics/Displays, it only gives me something about the integrated "Intel HD Graphics 4000". Can anyone else with the same model rMBP verify whether this is normal?

  • I am also facing the same issue, with same model mid 2012, from two weeks.. I went to a Apple center today for diagnosis.. But one small thing I found was, when the keyboard lights up, just close the lid.. It then goes to sleep.. Again open it.. You'll find your screen working normal.. I'm thinking that this problem occurs only at startup, but not at sleep.. This is not a solution, but a temporary remedy.. Get it checked with Apple service.. If you had any progress over this isuue, please inform me.. – user81370 Jun 10 '14 at 19:09
  • a Mid-2015 model?? Do you mean the Mid-2012 non retina model? – killswitch Jun 10 '14 at 19:18
  • Sorry.. Its mid 2012 retina model.. Intel I7 processor.. With integrated Intel graphics and dedicated NVDIA GPU.. – user81370 Jun 10 '14 at 20:00
  • What I meant to ask was, is it retina or non retina? – killswitch Jun 10 '14 at 20:00
  • mid 2012 retina model.. Intel I7 processor.. With integrated Intel graphics and dedicated NVDIA GPU – user81370 Jun 10 '14 at 20:01
1

Apple has launched MacBook Pro Repair Extension Program for Video Issues which can be found here

Apple has determined that a small percentage of MacBook Pro systems may exhibit distorted video, no video, or unexpected system restarts. These MacBook Pro systems were sold between February 2011 and December 2013.

Apple or an Apple Authorized Service Provider will repair affected MacBook Pro systems, free of charge.

  • The symptoms listed for the repair extension are graphics corruption and spontaneous shut downs. It's a reach to expect that to leak over to SMC issues like fan control and failure to even start. If this Mac had both issues and Apple would fix them for free, that would be great, but these don't seem to be in the same class of hardware fault to me. – bmike Feb 20 '15 at 13:30
  • @bmike It's hard to tell, OP listed problems with discrete Graphics Card. Anyway - repair is free and I think it's a good idea to inform the OP about that possibility. – Mateusz Szlosek Feb 20 '15 at 13:35
0

I see that you did a PRAM reset, but it doesn't hurt to try resetting PRAM continuously 4 to 6 times in a row quickly.

If you have remote access enabled or remote login, I would then boot and try to get logged into the system that way to better diagnose the issue.

Next I would try booting with various options such as with the shift key to disable extensions.

Next I would try to load the Apple's Hardware Test utility by holding down the d key on boot.

Next I would try booting from the System installer SD or DVD holding down the c or option keys, and in the options screen that you can't see, just pushing the right arrow once and guessing at the choice.

And if I had access to an external monitor to try, I would, again to attempt to get more diagnostic info from the system.

It does sound like the symptoms have a definite cause, such as a dead clock battery, or a bad graphics card, or even, unlikely though, a virus. If under warranty, contact Apple if you think it is a hardware issue. If not under warranty and you think it is a hardware issue, take it to your nearest Apple Store and ask to see the Apple Genius.

  • I just tried the PRAM reset 6 times in a row, no dice. With the trick I mentioned I can actually navigate the system. What diagnostics could I run? Unfortunately, the trick with the HDMI cable doesn't seem to work for the Apple Hardware Test. Is there a comparable test suite available as a regular application? – Mark May 8 '14 at 19:54
0

I also have a mid-2012 15" rMBP and have seen similar problems intermittently for the pst couple weeks.

I only notice it on startup. On the bad startups, the screen stays black and the computer won't start. The issue persists on reboot, smc reset, pram reset for an hour or two and then goes away.

Today it started again. After I got it booted in recovery, I noticed in syslog that the processor was thermal throttling. I listened for the fan and was surprised to not hear it, at all. This model may be prone to a bad temp sensor or fan controller issue.

I put an ice pack on the machine and it eventually booted but is running extemely slowly. Hopefully if I leave it for an hour it will come around.

I've noticed a couple other electrical oddities recently: right USB port doesn't always work, so I think I might need a new logic board.

  • I also got the thermal throttling and extreme slowness problems, although that only started in October (so a few months after the screen problems started for me). I'd gotten used to coping with the screen issues, but this basically rendered my rMBP useless. I could get it to boot and it would run okay, but then after some amount of time (usually half an hour) it would instantly become extremely sluggish and then just power down on its own. I ended up having to buy a new one. – Mark Nov 21 '14 at 18:52
  • Sorry to hear that. Took it to genius bar and tech suggested sending it into the depot for repairs. As long as there's no water damage, almost every repair is covered for $315 flat rate, including a new logic board, screen, etc if needed. So that's the plan: I'm sending it in in a couple days and will get it back in december. – Isaac Nov 23 '14 at 0:58
  • Oh that's not too bad. I was looking at €1000+ for a new logic board, so repairing just wasn't feasible. Can you update once you get it back with what they replaced and possible diagnoses? – Mark Nov 23 '14 at 10:23
  • 310 was a great deal! They replaced almost everything... New logic board, display/clamshell, io board, magsafe port, flex cable and right cable. The logic board replacement seems to have fixed the issue, the others were for a flaky usb port and disconnected/broken camera. – Isaac Dec 5 '14 at 6:33
0

This seems clearly GPU issue. Previously all 2011 model MBPs had the same issue and same symptoms. I am a victim myself. Take it to the authorized service center immediately. If you are out of warranty then it may be expensive to replace the logic board. I have sworn that I will not buy another Apple Mwith dual graphics.

0

Same thing happened to my late 2013 rMBP. The computer was on, the display wasn't. I got my display replaced by Apple for free under warranty.

0

I have had a similar issue - heard the start up chime but had a black screen. I shone a touch through the Apple logo on the back and saw that it was going to the login screen just without the screen lit. I was able to log in using the light from my torch and I didn't have the problem again.

I know it sound silly it worked for me, I have a mid 2012 mbp also

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .