11

I am using sshfs @2.5 and osxfuse @2.6.4 installed via MacPorts 2.2.1 on my MacBook Pro Retina Late 2013 which is running OS X Mavericks 10.9.2. When issuing the following command:

sshfs -ovolname=Z user@host:/somewhere/on/the/Y /Z

The mounting is done correctly. Using the terminal, everything works as expected. However, finder displays the volume name as Y, as if the presence of the volname= option didn't matter. Has anyone else encountered this?

8

The options go at the end of the command, so in your case:

sshfs user@host:/somewhere/on/the/Y /Z -o volname=Z

I just had a similar problem and this fixes it for me!

| improve this answer | |
  • just tried in the front and in the end - both worked just fine. – Geo Jun 5 '15 at 16:20
  • I thought it was silly too but it did seem to make a difference for me. I tried several times. It may have been something about my path that made the command parse differently. – zacharytamas Jun 5 '15 at 17:50
2

You need a space between the -o and the volname:

sshfs -o volname=Z user@host:/somewhere/on/the/Y /Z
        ^
| improve this answer | |
  • I tried what you suggested but it doesn't change anything :( – Nicolas De Jay May 7 '14 at 20:07
  • with the option at the end, -ovolname=Z works for me on mac. – seleciii44 Oct 6 '18 at 10:14
2

Struggling with this issue myself, I discovered that I needed to add the -o local option:

sshfs user@host:/somewhere/on/the/Y /Z -o volname=Z -o local

Beware that the OSXFUSE maintainers advise against this option, though, as it might invoke unwanted side-effects:

This option marks the volume being mounted as "local". By default, osxfuse volumes are marked as "nonlocal", which technically isn't necessarily the same as a "server" or "network" volume, but is treated as such by the Finder in some cases. For example, the Finder may not show "connected servers" on the Desktop or in the sidebar in some cases. If you use this option, you can get around this "limitation". However, wait! Don't be too tempted and think local is a magic pill that will solve all your problems. In fact, it may mess things up more than you realize. The operating system can be more aggressive in dealing with "local" volumes (a .Trashes. directory will be created, for one). You could run into mysterious problems with Disk Arbitration and other system components. I don't know (and possibly can't know--Mac OS X isn't all open source!) the side effects of using this option. Therefore, treat this as experimental and use with caution. Moreover, please do not file bug reports that involve this option--reproduce your issue without this option and then file a bug report.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .