0

I accidentally deleted the Mail folder (at /Library) that contained a few sub-folders including one called V2. I did that hoping to do a fresh configuration of my iCloud and Live accounts.

However, when I tried reopening mail.app, it wouldn't restore the said folder. It does prompt me to configure a mailbox which I do, selecting iCloud in my System Preferences window but the mailbox still doesn't appear! The preferences menu option of mail.app is also disabled. Please advise if anything can be done to get it back to normal without a system reinstall!

Here are some screenshots to illustrate the problem:

This is the first screen I get when opening Mail.app This is the first screen I get when opening Mail.app

Then I select the first option to set up my iCloud account Then I select the first option to set up my iCloud account

On the next screen, I check the Mail option and hit Add Account On the next screen, I check the Mail option and hit Add Account

After all this, my ~/Library/Mail/V2 folder still looks like this (no mailbox created) After all this, my ~/Library/Mail/V2 folder still looks like this (no mailbox created)

And the Preferences menu option in Mail.app is still disabled And the Preferences menu option in Mail.app is still disabled

Here's a Console dump: Here's a Console dump:

  • Deleting the accounts from System Preferences > Internet Accounts and readding them doesn't work? – thankyour May 6 '14 at 15:22
  • Unfortunately it didn't. Tried several times. :( – TheLearner May 6 '14 at 15:23
  • The Mail-Folder of your Account should be located in '~/Library/Mail' not '/Library/Mail' - i hope that was a Typo in your description. If you have manually created a 'Mail'-Folder in '~/Library' it could be a permission error. Quit Mail.app, start Console.app, then start Mail.app, check the Entries in Console.app and post the results. Perhaps there is a useful error message. – J.C. May 6 '14 at 15:51
  • Yes, I had meant ~/Library/Mail and no, I didn't create the Mail folder manually. It was automatically created when I restarted Mail.app. I will post the Console output shortly... – TheLearner May 6 '14 at 15:54
  • 1
    Instead of selecting "iCloud" when adding the account, try "Add Other Mail Account..." and follow the configuration steps. – thankyour May 6 '14 at 16:12
2

Instead of selecting "iCloud" when adding the account, try "Add Other Mail Account..." and follow the configuration steps. Repost from comment for thread closure.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .