1

When I type a reply email multiple copies of this email get saved in drafts.

I've read over the posts tagged mail.app and I thought I hit the jackpot with this answer by @Kyle, but when I navigate to Accounts>Mailbox Behaviours there is no option for disabling saving drafts on the server, or am I missing something? enter image description here I am running Mail 7.2 on an MBP with OS X Mavericks 10.9.2

When I type a reply email multiple copies of this email get saved in drafts, then these drafts all appear when I have View>Organize by Conversation ticked. Our company uses gmail as our mail service. This does not happen when I use my own gmail account.

This is really annoying as when I am writing a long email, there can be an additional 20 "emails" in the email trail.

I get the same behaviour whether I am running IMAP or POP.

Is there a way to stop this?

  • please explain using your own gmail account? is it on same computer, is it also in the work place or at home, – Ruskes May 7 '14 at 8:02
  • @Buscar웃 when I say my own gmail account I mean my personal gmail account. I have set it up on the same computer that has the issue (running 10.9.2), and also on a different MBP running 10.7.5. This happens both at work and at home. If I have not made anything clear please let me know I can provide more screenshots etc. Also I can jump on chat. – Deesbek May 9 '14 at 14:36
  • Well your "Mailbox behavior" is mess up? it is missing a option "Draft"? so I wanted to know if that is same on both accounts, and if it is you need to fix your mail.app installation. – Ruskes May 9 '14 at 17:02
  • Let me check, one tick, I get what you are saying. – Deesbek May 9 '14 at 17:09
  • @Buscar웃 I think I found the issue, the drafts configuration in "Mailbox behaviours" only appears for IMAP accounts, it does not appear for POP accounts, as I have been trying to resolve this I set up a POP account rather than an IMAP. – Deesbek May 9 '14 at 17:18
0

The reason for this issue was the fact that I had set up the account as a POP account in apple mail.

When IMAP is selected the following screen appears: enter image description here and as can be seen the first item is the one I was looking for.

Drafts : Store draft messages on the server.

When the option above is not ticked the issue stops.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .