What do I need to do to prevent the iOS 7 Music app from listing songs twice when the song should only exist once?

I sync a selection of playlists to my iPhone 5s from iTunes 11.1.5 on my iMac running OS X 10.7.5. For at least one artist, album tracks are listed twice on my iPhone despite appearing only once in my iTunes library. I count 16 duplicates out of 53 songs for this artist on my phone. (The artist is Front 242, which I mention mostly for my own reference.)

I checked my iTunes library on the iMac, and I only have one copy of the affected songs there.

I am not using iTunes Match.

Curiously, during playback, songs are not repeated if I move forwards or backwards through a list that includes duplicated songs.

What I tried

In an attempt to solve this, I unchecked "Sync Music" and applied the change with my iPhone connected to my iMac, so all songs were removed. Then I checked "Sync Music" again (and thankfully my previous selection of playlists was preserved), and the music went back on my phone. Same problem.

What I didn't try

I haven't tried marking either individual albums or the artist for inclusion on my phone, just one or more playlists that include these songs.

I haven't tried swiping to delete individual songs, because I'd first want to determine all of the playlists containing that song, and do a time-consuming before-and-after check on my phone to ensure that removing the apparently duplicated song doesn't change my playlists.

  • Were these songs purchased from the iTunes Store?
    – Dillon
    Commented May 21, 2014 at 17:00
  • No, these songs were imported from CDs.
    – bneely
    Commented Jun 12, 2014 at 3:10
  • I can't post an answer but I had this same issue and it seems to be caused by converting higher bitrate songs to, e.g. 128 kBs AAC. Turning this off and resyncing fixed it for me. Commented Jan 23, 2015 at 12:04

5 Answers 5


What I would try:

  1. Make a current backup your iPhone via either iTunes or iCloud.
  2. Eject the iPhone from iTunes.
  3. iPhone Settings > General > Usage > Storage > Music > Edit > Delete
  4. Reboot your iPhone
  5. Connect your iPhone to iTunes and attempt to manually sync the playlists in question.
  • Another thing to note, it is possible to view and delete songs on the device directly from iTunes. However, to do a complete wipe and restart on the device, this method worked for me. I also did the manual/automatic switch described in the answer below.
    – Shanerk
    Commented Mar 4, 2015 at 13:32

Assuming the duplicated songs were purchased from iTunes, you can go to Settings > iTunes & App Store, then turn off "Show All - Music". This toggle shows all the songs you have purchased regardless of if it is on your device or not.

  • What's bizarre is that I did this exact thing and it worked -- until today. Now the new version of iTunes overrode this fix and songs appear twice again. Any tips?
    – user90932
    Commented Sep 17, 2014 at 1:50

What I did:

  1. Sync your iPhone with iTunes.
  2. In iTunes, click Summary and uncheck Manually manage music and videos OR go to Music and uncheck Sync Music.
  3. When prompted whether you wish to proceed -- because unchecking means the current music files in your phone will be erased, which is what you want to do to resolve this problem -- click Remove and Sync.
  4. Next, eject the phone. Check phone to see if all music files are marked by the 'cloud download' icon, which indicates you successfully removed all iTunes files from your phone.
  5. For further inspection, find the problem files that had shown up as duplicates on your phone. For me, the problematic tracks were no longer duplicated. If you still find duplicates on your phone, then go to iTunes, select 'Music', then select "Show Duplicate Items" from the View pull-down menu. Here you can delete any duplicate items. If you are using iTunes 12.01, click the 'Done' button when finished viewing file duplicates.
  6. Restart your iPhone and connect to computer.
  7. In iTunes, click Summary. Now with the problem resolved, you check Manually manage music and videos. OR in iTunes, click Music and check Sync Music.

Hopefully this works, if not, it's something to do with iCloud. Try disabling that and just backup on your computer. Then do it again.


This is a known issue actually. I have experienced similar issues many times. When I have an issue where my iPhone playlist contents don't match my iTunes playlist contents, I do this:

  1. For this excercise, let's say one of my Playlists is "Steely Dan", however iTunes and the Music app don't match, or the songs on my phone won't sort the same as they do on iTunes.

  2. Create another playlist called "Steely Dan 2".

  3. In the original "Steely Dan" playlist, select all songs, click and drag to the "Steely Dan 2" playlist.

  4. Delete the "Steely Dan" playlist.

  5. Rename the "Steely Dan 2" playlist to "Steely Dan".

  6. Plug in your phone and sync again.


Try this to view if you really have duplicate items on your iTunes library: Click View, and than "Show Duplicate Items"

enter image description here

  • @bneely said he/she only has one copy of the songs that are being duplicated in iTunes.
    – Dillon
    Commented May 21, 2014 at 16:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .