I've been attempting to mount a network server on my computer. I can do it through Finder, but this is inconvenient since I can only connect with one username at a time. I read that mounting via Terminal would allow me to connect with multiple usernames at the same time. I found this post: How can I mount an SMB share from the command line? where the command to mount is

mount_smbfs //user@SERVER/folder ./mntpoint

but whether I do that or mount -t smbfs instead of mount_smbfs I get the same error:

mount_smbfs: mount error: [mountpoint path]: Input/output error

Someone even mentioned getting the same error in that post I linked to above, but no one answered him.

Edit: For the sake of being complete, here's my actual input and output (with the username and password replaced). I even created a new directory /Volumes/testShare to test it with.

Jamess-MacBook-Pro:Volumes magavendon$ mount -t smbfs //[user]:[password]@ /Volumes/testShare
mount_smbfs: mount error: /Volumes/testShare: Input/output error

And the mount_smbfs command:

Jamess-MacBook-Pro:Volumes magavendon$ mount_smbfs //[user]:[password]@ /Volumes/testShare
mount_smbfs: mount error: /Volumes/testShare: Input/output error
  • you did change the ./mntpoint to a valid path, right ?
    – rwenz3l
    Commented May 5, 2014 at 22:36

2 Answers 2


You probably need to do mkdir ./mntpoint first.

For example:

mkdir /Volumes/home
mount_smbfs //tom:tomspassword@fileserver/home /Volumes/home
  • I did already create the directory. I even tried a different directory ./test just in case.
    – James
    Commented May 5, 2014 at 20:08
  • yes, but try removing the dot. The Dot is translated as "Current Directory". The / is the root directory. So basics here: cd /Volumes = Volumes folder in root of HDD; cd . = Current directory; cd ./Desktop = Desktop folder in your home folder; cd ~ = your home folder; Now if you try to mount a Volumes at ./test it creates the mountpoint in the current dir under currentDir/test.
    – rwenz3l
    Commented May 5, 2014 at 23:00
  • Thank you. Sorry I guess my previous statement wasn't very clear. I didn't make a directory called ./test just test. I used ./test when passing the directory I wanted to put the mount point in for the mount command.
    – James
    Commented May 6, 2014 at 12:43
  • In Unix, you never have to say ./ but it has spread like a plague among the clueless. Unix paths can be absolute - beginning with / - which gives the path starting from the root directory, whose path is /. Anything else - not beginning with / - is relative and gives a path that starts from the current working directory. This is true by definition. Starting a path with ./ is entirely redundant since . means the current working directory. There are undoubtedly obscure exceptions to this rule, like modules in JavaScript source, but, otherwise, don't start paths with ./.
    – Denis Howe
    Commented Jul 8 at 13:56

So, you want to go the hard way, here you go :

mkdir /Volumes/[share] | mount_smbfs //[user]:[password]@[server]/[share] /Volumes/[share]


You can connect multiple times to the same server
with different users via the ⌘ cmd + K Box in Finder.

Basically: smb://user@server (or SMB1 = cifs://user@server).

It automatically adds the a number to every duplicate share that is connected,
so if you have "Data" twice on the server, but for different users, or for same users, but with different priviliges, then Mac creates /Volumes/Data first, then on the second connection creates /Volumes/Data-1.

But this is not visible to the User, you see both as "Data" Sharepoints in Finder.

  • I did figure out how to connect this way through Finder. But when I connect with a different user the data that should be in that user's directory doesn't show up. I was hoping that if I could mount through terminal that might solve my problem. Furthermore, even if I did get the user's data to show up in Finder when logging in with the correct user I still wouldn't be able to log in with multiple users at the same time, which is what I want to do.
    – James
    Commented May 6, 2014 at 12:50
  • Just to clarify. My problem input/output error isn't that I don't have the directory correctly named or existing. I know how to do that.
    – James
    Commented May 6, 2014 at 12:52
  • If you've already authenticated with the SMB server as one user, Finder ignores the user@ part of the URI and just proceeds as the user you've already connected as. Commented Dec 5, 2021 at 5:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .