3

I have setup 2 Desktops in Mavericks (Mission Control).

  • On "Desktop 2" there are some programs that need to run, but which I use rarely, for example a Terminal with some server tasks.
  • Then on "Desktop 1" I want to run more Terminal instances, but when I click the icon in the dock, it jumps to the Terminal instance on the second desktop.

I tried disabling this setting, but then clicking the app icon does nothing (second click jumps to desktop 2):

  • System Preferences > Mission Control > When switching to an application, switch to a space with open windows for the application

Any ideas or tools to solve this problem? Basically I want Mavericks to treat every Desktop separately.

1

It seems that what you are doing does not work the first time, but after 2 tries, it does. So do this to the 'When switching to an application, switch to a space with open windows for the application':

  1. Turn it OFF in System Preferences → Mission Control
  2. Turn it ON
  3. Turn it OFF again.

You could also try typing this in Terminal:

defaults write com.apple.dock workspaces-auto-swoosh -boolean NO

...but that is said to only work in OSX Leopard on the website above but 'jgl777' over here said that it worked on his 10.8.3 Mountain Lion, so it's possible it could work on Mavericks. I would advise backing up if you do this, but you should be doing that even if you don't want to use this method!

Another option is to Ctrl + Click the application's icon in the dock and then click open in new window, this will open it in the current Desktop and a new window of the app.

  • With the setting disabled it only activates Terminal, but doesn't open a new window. Thanks for the tip with Ctrl-Click! – Ikarus May 3 '14 at 19:51
2

At least on El Capitan, it is (apparently) necessary to restart the Dock after setting the value of workspaces-auto-swoosh

On the command line:

defaults write com.apple.dock workspaces-auto-swoosh -boolean NO
killall Dock

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .