When I plug in my Nexus 5 into my Mid 2013 MacBook Air 11" nothing happens. It doesn't show up in the finder / on the desktop and when I enable USB tethering, it doesn't show up in my network preferences.

But when I connect the USB cable with Nexus 5 while parallels with Windows 8.1 is running and choose to use the connected device in Windows 8.1 - everything works as expected.

So the problem isn't anywhere in the hardware, nor in my Nexus 5, but somewhere in the OS X.

Any ideas how to find more info, fix it?


In the System Report generated by About This Mac, I can see my device connected via USB.

  • When you say nothing happens in OS X — Parallels is not running at that time, correct?
    – samh
    Commented Aug 25, 2014 at 19:41

3 Answers 3


Not sure if you ever solved this as its 30 days old, but in OS X you need The Android File Transfer App running in the background in order to mount your Android shares. Hope this helps.

  • 1
    I had a similar problem, and downloaded the 'Android File Transfer App' suggested by user3623501 and it worked.
    – user88753
    Commented Aug 25, 2014 at 19:23

I had a similar issue albeit in my case the cause was my usb cable. It was manufactured for power supply and hence let no data through. Switching the cable let me connect my Android device without further problems.

  • 1
    Cable shouldn't be the problem as it works with all other computers I've tried as well as Windows 8 running inside mavericks with parallels. The android file transfer does work, however it doesn't solve my problem that I just want raw access to the phones memory card via mount like I have in Linux.
    – peter
    Commented Aug 25, 2014 at 13:56
  • @zahorak I know that this will not fix your problem. This question was the first to come up in a google search for my problem though.
    – k0pernikus
    Commented Aug 25, 2014 at 13:58
  • Thanks a lot !! That helped me to solve the same problem with my Nexus 5 :) !
    – Val
    Commented Oct 5, 2014 at 16:29

My solution strictly involved replacing the cable. I found the original cable for the Nexus 5 and the problem cleared. Two other cabled failed to activate the program in my macbook air.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .