2

I am running Jabref v2.10 on Mac OS X 10.9.2. After changing some parts of the configuration file manually, I seem to have broken the preferences and now it fails to start. The application stores the application preferences using the java.util.prefs library. Is there a way I can delete java's stored preferences in Mac? (E.g., in linux, I would just delete the ~/.java folder)

3

From Apple Developer Connection:

The preferences files generated by the Preferences API are named com.apple.java.util.prefs. The user’s preferences file is stored in their home directory (~/Library/Preferences/). The system preferences are stored in /Library/Preferences/ and are only persisted to disk if the user is an administrator.

I do not know if you can simply delete them though.

  • 1
    I had already tried deleting java, jabref specific files in ~/Library, but the problem had persisted. Apparently you need to restart your computer for changes to take place. (Seriously Oracle?) Anyways, that solves my problem – Shitikanth May 3 '14 at 15:41
  • Good to know. :) – kourbou May 3 '14 at 16:01
  • @kourbou I tried to delete this file, and reboot, but preferences are still present. Maybe I miss something? – Panayotis Jan 26 '17 at 8:11
1

This problem hit me recently so I thought I'd post the answer here belatedly.

When you delete the preferences on a Mac (plist file) make sure you clear the cached preferences otherwise Java programs can keep working with the cached settings. You can:

  1. Delete the plist file
  2. killall -u <your-user-name> cfprefsd

    OR

  3. reboot

Items 2. and 3. will cause the cache to be cleared and then your preferences will be reloaded as cfprefsd restarts automatically.

I hope that helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .