1

I'm trying to start Sony Sound Forge Pro. It's worked before, but then I tried to update to version 2 of the app, and I started getting this error when I start it. I downgraded back to version 1 and I still get the error.

The error is in the Console and it looks like this:

5/1/14 8:15:25.000 PM kernel[0]: CODE SIGNING: cs_invalid_page(0x10d2c1000): p=490[CoreServicesUIAg] final status 0x1000a00, denying page sending SIGKILL

5/1/14 8:15:25.000 PM kernel[0]: CODE SIGNING: process 490[CoreServicesUIAg]: rejecting invalid page at address 0x10d2c1000 from offset 0x11000 in file "/Applications/Sound Forge Pro.app/Contents/MacOS/Sound Forge Pro" (cs_mtime:1365521695.0 == mtime:1365521695.0) (signed:1 validated:1 tainted:1 wpmapped:0 slid:0)

Is there any way to "reset" Apple's code signing and allow this application to run again?

7

You could ad-hoc sign the program yourself if you know it is a valid program, and not malware or similar.

From Terminal.app run a command like this:

sudo codesign -f -s - "/Applications/Sound Forge Pro.app/Contents/MacOS/Sound Forge Pro"

"-f" means to force replace the existing, faulty, signature "-s -" means to ad-hoc sign

The rest is the completely path and filename of the executable you want to sign.

  • thanks for the answer! Still having some trouble... this is what I get when I run that: dpaste.com/05Z7HVM And I still get the same console error. – nnyby May 13 '14 at 21:47
  • Try adding --deep to the command, so it looks like this: sudo codesign -f --deep -s - "/Applications/Sound Forge Pro.app/Contents/MacOS/Sound Forge Pro" – jksoegaard May 14 '14 at 7:16
  • Same results with the --deep option – nnyby May 14 '14 at 14:34
  • Have you checked that there is a Info.plist file for that framework within that folder? - If not, you need one. – jksoegaard May 14 '14 at 16:45
  • I was able to get this to work with your command! sudo codesign -f -s - "/Applications/Sound Forge Pro.app/Contents/MacOS/Sound Forge Pro". I'm not sure what changed since last time, but I ran this command after deleting any trace off the app n ~/Library/, and with a new user account, and after re-installing it. – nnyby Aug 24 '14 at 22:48
1

Here's a couple workarounds to try if you can't find an answer:

1) Time Machine

Use a Time Machine backup from before you upgraded as a system restore point.

2) Temporary User Account

Create a temporary user account, see if the error still occurs when logged into the temporary account, and if not, return to the Finder and enter:

  shift-command-g

and in the field that appears type:

  ~/Library

and in the window that appears, take a look in these folders for preferences for the name of app in question, or the name of its developer:

 ~/Library/Preferences/
 ~/Library/Application\ Support/
 ~/Library/Caches/

and copy these files into a folder with a duplicate folder structure:

 /Users/Shared/mytempLibrary/Preferences/
 /Users/Shared/mytempLibrary/Application\ Support/name.of.folders
 /Users/Shared/mytempLibrary/Caches/name.of.folders

Log out and back into your main account and use the files you copied to /Users/Shared to replace the same files in your ~/Library by reitering some or all instructions in proper sequence to accomplish this.

  • The error still occurs in a new user account. – nnyby Aug 24 '14 at 22:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .