0

In two instances I have have a number of Mac Minis and iMacs that were not connected to the Internet but a local isolated LAN have their SMB:// shares refuse to connect, though they worked days or weeks before with no configuration changes.

After some testing I found that AFP:// and CIFS:// connections still worked using the same username and password as the non working SMB connections.

Since 10.9.x uses SMB by default now I wanted to figure out what was causing the issue instead of switching to AFP or CIFS as many have suggested.

1

Answering my own question since I had not seen this specific question answered.

After some log searching I finally found out that the issue was because the time on one of the machines was drifting causing it to become more than 5 minutes off from the computer it was connecting to and the server (computer connecting to) was displaying this log entry:

<date> <time> kdc[80]: Too large time skew, client time <time> is out by 356 > 300 seconds -- <user>@LKDC:<SHA1>

After finding this log entry I noticed and corrected the local time on the machines and the SMB connection via finder worked right away as expected.

The moral of this story is don't trust the Mac internal time without NTP backup; either via the Internet or a local NTP server.

  • so you ask a question that you already know the answer to... – Ruskes May 1 '14 at 20:58
  • Isn't that the point of the Answer your own question button on the question page? blog.stackoverflow.com/2011/07/… – hoss May 1 '14 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .